summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Mocciola2016-05-03 18:44:29 +0200
committerMichele Mocciola2016-05-03 18:44:29 +0200
commit4132391ac2af70b35da8f44a86a40b9dbac71954 (patch)
tree1aaf9c5e2f9a74b1ffb8f4769f5f6e4f40d4a350
parent4fbd8ca7abccd983ef9a607d033a799fedf92e15 (diff)
downloadaur-4132391ac2af70b35da8f44a86a40b9dbac71954.tar.gz
Modified to compile with gcc-5.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a475dd5e9f9b..e2aaed462fa4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue May 3 16:43:52 UTC 2016
pkgbase = ifcopenshell-git
pkgdesc = Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version.
- pkgver = 0.r355.gc6a265a
- pkgrel = 2
+ pkgver = 0.r548.gfefa8a0
+ pkgrel = 1
url = http://ifcopenshell.org/
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 8e4d29bbc760..64b3c8c39bdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: mickele <mimocciola[at]yahoo[dot]com>
pkgname=ifcopenshell-git
-pkgver=0.r355.gc6a265a
-pkgrel=2
+pkgver=0.r548.gfefa8a0
+pkgrel=1
pkgdesc="Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version."
url="http://ifcopenshell.org/"
arch=('x86_64' 'i686')
@@ -32,6 +32,10 @@ prepare(){
sed -e 's|\t#include "../ifcgeom/IfcGeom.h"|\t// #include "../ifcgeom/IfcGeom.h"|' -i src/ifcwrap/IfcPython.i
sed -e 's|\t#include "../ifcgeom/IfcGeomIterator.h"|\t#include "../ifcgeom/IfcGeomIterator.h"\n\t#include "../ifcgeom/IfcGeom.h"|' -i src/ifcwrap/IfcPython.i
+
+ sed -e "s|FIND_PACKAGE(Boost REQUIRED COMPONENTS system program_options regex thread date_time)|FIND_PACKAGE(Boost REQUIRED COMPONENTS system program_options regex thread date_time)\nADD_DEFINITIONS(-DBOOST_OPTIONAL_USE_OLD_DEFINITION_OF_NONE)|" -i cmake/CMakeLists.txt
+
+ sed -e "s|boost::shared_ptr<Representation::Triangulation<P>>|boost::shared_ptr<Representation::Triangulation<P> >|" -i src/ifcgeom/IfcGeomElement.h
}
build() {
@@ -42,6 +46,7 @@ build() {
local _pythonver=$(python --version >&1)
cmake ../cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_STANDARD=11 \
-DOCC_INCLUDE_DIR=/opt/opencascade/inc \
-DOCC_LIBRARY_DIR=/opt/opencascade/lib \
-DOPENCOLLADA_INCLUDE_DIR=/usr/include/opencollada \