summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Mocciola2015-10-25 22:51:25 +0100
committerMichele Mocciola2015-10-25 22:51:25 +0100
commit4fbd8ca7abccd983ef9a607d033a799fedf92e15 (patch)
tree324605f39e6a5a7b829f586e334c8bbe8f6a2557
parent9238da737ec5edef8e2ae7773e8c4d59fd0b53eb (diff)
downloadaur-4fbd8ca7abccd983ef9a607d033a799fedf92e15.tar.gz
Added blender addon
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f5df3ddefc0..a475dd5e9f9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ifcopenshell-git
- pkgdesc = Open source IFC library and geometry engine. Provides static libraries and python3 wrapper. GIT version.
+ pkgdesc = Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version.
pkgver = 0.r355.gc6a265a
- pkgrel = 1
+ pkgrel = 2
url = http://ifcopenshell.org/
arch = x86_64
arch = i686
@@ -12,7 +12,6 @@ pkgbase = ifcopenshell-git
depends = opencascade
depends = opencollada
depends = boost-libs>=1.58.0
- depends = python2
depends = python
conflicts = ifcopenshell
source = IfcOpenShell::git://github.com/IfcOpenShell/IfcOpenShell.git
diff --git a/PKGBUILD b/PKGBUILD
index abb1f89b68fe..8e4d29bbc760 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: mickele <mimocciola[at]yahoo[dot]com>
pkgname=ifcopenshell-git
pkgver=0.r355.gc6a265a
-pkgrel=1
-pkgdesc="Open source IFC library and geometry engine. Provides static libraries and python3 wrapper. GIT version."
+pkgrel=2
+pkgdesc="Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version."
url="http://ifcopenshell.org/"
arch=('x86_64' 'i686')
license=('GPL3')
-depends=('opencascade' 'opencollada' 'boost-libs>=1.58.0' 'python2' 'python')
+depends=('opencascade' 'opencollada' 'boost-libs>=1.58.0' 'python')
optdepends=()
makedepends=('cmake' 'boost>=1.58.0' 'swig')
conflicts=('ifcopenshell')
replaces=()
backup=()
source=('IfcOpenShell::git://github.com/IfcOpenShell/IfcOpenShell.git')
+_blenderver=2.76
pkgver() {
cd IfcOpenShell
@@ -57,6 +58,11 @@ package() {
cd "${srcdir}/IfcOpenShell"
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+
+ mkdir -p "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib
+ cp -rf "${srcdir}"/IfcOpenShell/src/ifcblender/* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib
+ cp -rf "${srcdir}"/IfcOpenShell/src/ifcopenshell-python/* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib/io_import_scene_ifc
+ cp -f "${srcdir}"/IfcOpenShell/build/ifcwrap/*ifcopenshell_wrapper* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib/io_import_scene_ifc/ifcopenshell
}
md5sums=('SKIP')