summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNahouhak2023-04-10 16:21:32 +0200
committerNahouhak2023-04-10 16:21:32 +0200
commit8080d47aa1390fe61a2ef2ed13c1440ce3a149fe (patch)
treed2d1f8ec94f8e2618950c3323674b8d0b4f8889e
parentba3278f821bee314a690586c2620a5dfb2805b74 (diff)
downloadaur-8080d47aa1390fe61a2ef2ed13c1440ce3a149fe.tar.gz
Add dependencies shapely and bpypolyskel
- optional dependency python-shapely - bpypolyskel as submodule
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6176c2bf4237..925ea3945880 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ifcopenshell-git
pkgdesc = Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version.
- pkgver = 230107.r2.g73d43649a
+ pkgver = 230410.r7.ge71ee988b
pkgrel = 1
url = http://ifcopenshell.org/
arch = x86_64
@@ -40,6 +40,7 @@ pkgbase = ifcopenshell-git
optdepends = python-toposort: ifcpatch
optdepends = python-xsdata: blender bim addon
optdepends = python-brickschema: brickschema support
+ optdepends = python-shapely>=2.0.1: blender bim addon space generation support
provides = ifcopenshell
provides = blender-plugin-bim
provides = IfcConvert
@@ -53,6 +54,8 @@ pkgbase = ifcopenshell-git
source = git+https://github.com/IfcOpenShell/svgfill.git
source = git+https://github.com/svgpp/svgpp.git
source = https://github.com/BrickSchema/Brick/releases/download/nightly/Brick.ttl
+ source = git+https://github.com/prochitecture/bpypolyskel.git
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f2019059c2ba..467ada5e9ced 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Cyril Waechter <cyril[at]biminsight[dot]ch>
# Contributor: mickele <mimocciola[at]yahoo[dot]com>
pkgname=(ifcopenshell-git blender-plugin-bim-git)
-pkgver=230107.r2.g73d43649a
+pkgver=230410.r7.ge71ee988b
pkgrel=1
pkgdesc="Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version."
arch=('x86_64' 'i686')
@@ -24,7 +24,8 @@ optdepends=('python-svgwrite: blender bim addon svg support'
'python-olca-ipc: blender bim addon life cycle analysis support'
'python-toposort: ifcpatch'
'python-xsdata: blender bim addon'
- 'python-brickschema: brickschema support')
+ 'python-brickschema: brickschema support'
+ 'python-shapely>=2.0.1: blender bim addon space generation support')
makedepends=('cmake' 'boost>=1.58.0' 'swig' 'python-babel')
provides=('ifcopenshell' 'blender-plugin-bim' 'IfcConvert' 'IfcGeomServer' 'python-ifcpatch' 'python-ifcdiff' 'python-bcf' 'python-bimtester' 'python-ifccsv')
conflicts=()
@@ -33,7 +34,8 @@ backup=()
source=("git+https://github.com/IfcOpenShell/IfcOpenShell.git"
"git+https://github.com/IfcOpenShell/svgfill.git"
"git+https://github.com/svgpp/svgpp.git"
- "https://github.com/BrickSchema/Brick/releases/download/nightly/Brick.ttl")
+ "https://github.com/BrickSchema/Brick/releases/download/nightly/Brick.ttl"
+ "git+https://github.com/prochitecture/bpypolyskel.git")
_blender_ver=$(blender --version | grep -Po 'Blender \K[0-9].[0-9]+')
_python_ver=$(python --version | grep -Po 'Python \K[0-9].[0-9]+')
@@ -46,6 +48,12 @@ prepare() {
git submodule init
git config submodule.svgpp.url "${srcdir}/IfcOpenShell/src/svgfill/3rdparty/svgpp/"
git submodule update
+ cd "${srcdir}/IfcOpenShell/src/blenderbim/blenderbim/libs/site/packages/"
+ mkdir -p "bpypolyskel"
+ cd "bpypolyskel"
+ git submodule init
+ git config submodule.bpypolyskel.url "${srcdir}/IfcOpenShell/src/blenderbim/blenderbim/libs/site/packages/bpypolyskel/"
+ git submodule update
sed -i 's/lib_ext a/lib_ext so/' ${srcdir}/IfcOpenShell/cmake/CMakeLists.txt
cp "${srcdir}/Brick.ttl" "${srcdir}/IfcOpenShell/src/blenderbim/blenderbim/bim/schema"
}
@@ -116,4 +124,4 @@ package_blender-plugin-bim-git() {
chmod -R a+rwX "${pkgdir}/usr/share/blender/${_blender_ver}/scripts/addons/blenderbim/bim/data"
}
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')