summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Mocciola2015-10-25 21:58:16 +0100
committerMichele Mocciola2015-10-25 21:58:16 +0100
commit9238da737ec5edef8e2ae7773e8c4d59fd0b53eb (patch)
tree0d774f21bde1dceb5bec7d5b05c530261a64e2ce
downloadaur-9238da737ec5edef8e2ae7773e8c4d59fd0b53eb.tar.gz
Initial upload
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD62
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f5df3ddefc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ifcopenshell-git
+ pkgdesc = Open source IFC library and geometry engine. Provides static libraries and python3 wrapper. GIT version.
+ pkgver = 0.r355.gc6a265a
+ pkgrel = 1
+ url = http://ifcopenshell.org/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = cmake
+ makedepends = boost>=1.58.0
+ makedepends = swig
+ depends = opencascade
+ depends = opencollada
+ depends = boost-libs>=1.58.0
+ depends = python2
+ depends = python
+ conflicts = ifcopenshell
+ source = IfcOpenShell::git://github.com/IfcOpenShell/IfcOpenShell.git
+ md5sums = SKIP
+
+pkgname = ifcopenshell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abb1f89b68fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: mickele <mimocciola[at]yahoo[dot]com>
+pkgname=ifcopenshell-git
+pkgver=0.r355.gc6a265a
+pkgrel=1
+pkgdesc="Open source IFC library and geometry engine. Provides static libraries and python3 wrapper. GIT version."
+url="http://ifcopenshell.org/"
+arch=('x86_64' 'i686')
+license=('GPL3')
+depends=('opencascade' 'opencollada' 'boost-libs>=1.58.0' 'python2' 'python')
+optdepends=()
+makedepends=('cmake' 'boost>=1.58.0' 'swig')
+conflicts=('ifcopenshell')
+replaces=()
+backup=()
+source=('IfcOpenShell::git://github.com/IfcOpenShell/IfcOpenShell.git')
+
+pkgver() {
+ cd IfcOpenShell
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+prepare(){
+ cd "${srcdir}/IfcOpenShell"
+
+ sed -e 's|#include "SvgSerializer.h"|#include "SvgSerializer.h"\n#include <Standard_Version.hxx>|' -i src/ifcconvert/SvgSerializer.cpp
+
+ sed -e 's|\t#include "../ifcgeom/IfcGeom.h"|\t// #include "../ifcgeom/IfcGeom.h"|' -i src/ifcwrap/IfcPython.i
+ sed -e 's|\t#include "../ifcgeom/IfcGeomIterator.h"|\t#include "../ifcgeom/IfcGeomIterator.h"\n\t#include "../ifcgeom/IfcGeom.h"|' -i src/ifcwrap/IfcPython.i
+}
+
+build() {
+ cd "${srcdir}/IfcOpenShell"
+
+ mkdir -p build
+ cd "${srcdir}/IfcOpenShell/build"
+ local _pythonver=$(python --version >&1)
+ cmake ../cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DOCC_INCLUDE_DIR=/opt/opencascade/inc \
+ -DOCC_LIBRARY_DIR=/opt/opencascade/lib \
+ -DOPENCOLLADA_INCLUDE_DIR=/usr/include/opencollada \
+ -DOPENCOLLADA_LIBRARY_DIR=/usr/lib/opencollada \
+ -DPYTHON_INCLUDE_DIR:PATH=/usr/include/python${_pythonver:7:3}m \
+ -DPYTHON_LIBRARY:FILEPATH=/usr/lib64/libpython${_pythonver:7:3}m.so
+ make
+
+}
+
+package() {
+ cd "${srcdir}/IfcOpenShell/build"
+ make DESTDIR="${pkgdir}" install
+
+ cd "${srcdir}/IfcOpenShell"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+md5sums=('SKIP')