summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyrilWaechter2020-07-26 17:56:40 +0200
committerCyrilWaechter2020-07-26 17:56:40 +0200
commitb296eea6b26d2038e295875f776146d659315b29 (patch)
tree25537cf4f8739179ae88e7772c1f1a68e341b8b5
parentf457b09ce0a8e302e0ad3c1535a1779f6fadcd46 (diff)
downloadaur-b296eea6b26d2038e295875f776146d659315b29.tar.gz
Add Blender BIM Addon installation
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 36 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54ad0db736bb..9255d55690ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ifcopenshell-git
pkgdesc = Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version.
- pkgver = 0.6.0b0.r875.g607e5067
+ pkgver = 0.6.0b0.r928.g21a46808
pkgrel = 1
url = http://ifcopenshell.org/
arch = x86_64
@@ -14,8 +14,18 @@ pkgbase = ifcopenshell-git
depends = icu
depends = opencollada
depends = python
+ depends = nlohmann-json
+ optdepends = python-svgwrite: blender bim addon svg support
+ optdepends = python-occ-core: blender bim addon cut ifc support
+ optdepends = python-pystache: blender bim addon
+ optdepends = python-numpy: blender bim addon cut ifc support
+ optdepends = python-fcl: ifcclash
+ optdepends = python-deepdiff: ifcdiff
+ optdepends = python-pyparsing: ifcexpressparser support
+ optdepends = python-requests: blender bim addon covetool support
+ optdepends = python-lark-parser: util, ifccsv, ifcclash support
provides = ifcopenshell
- provides = IfcBlender
+ provides = blender-plugin-bim
provides = IfcConvert
provides = IfcGeomServer
conflicts = ifcopenshell
diff --git a/PKGBUILD b/PKGBUILD
index bd6e25a764d9..9ff9bb3fbfe9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,24 @@
# Maintainer: Cyril Waechter <cyril[at]biminsight[dot]ch>
# Contributor: mickele <mimocciola[at]yahoo[dot]com>
pkgname=ifcopenshell-git
-pkgver=0.6.0b0.r875.g607e5067
+pkgver=0.6.0b0.r928.g21a46808
pkgrel=1
pkgdesc="Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version."
arch=('x86_64' 'i686')
url="http://ifcopenshell.org/"
license=('LGPL3')
-depends=('boost-libs>=1.58.0' 'opencascade' 'icu' 'opencollada' 'python')
-optdepends=()
+depends=('boost-libs>=1.58.0' 'opencascade' 'icu' 'opencollada' 'python' 'nlohmann-json')
+optdepends=('python-svgwrite: blender bim addon svg support'
+ 'python-occ-core: blender bim addon cut ifc support'
+ 'python-pystache: blender bim addon'
+ 'python-numpy: blender bim addon cut ifc support'
+ 'python-fcl: ifcclash'
+ 'python-deepdiff: ifcdiff'
+ 'python-pyparsing: ifcexpressparser support'
+ 'python-requests: blender bim addon covetool support'
+ 'python-lark-parser: util, ifccsv, ifcclash support')
makedepends=('cmake' 'boost>=1.58.0' 'swig')
-provides=('ifcopenshell' 'IfcBlender' 'IfcConvert' 'IfcGeomServer')
+provides=('ifcopenshell' 'blender-plugin-bim' 'IfcConvert' 'IfcGeomServer')
conflicts=('ifcopenshell')
replaces=()
backup=()
@@ -43,7 +51,7 @@ build() {
-DOCC_LIBRARY_DIR=/usr/lib \
-DLIBXML2_INCLUDE_DIR=/usr/include/libxml2 \
-DLIBXML2_LIBRARIES="/usr/lib/libxml2.so.2" \
- -DJSON_INCLUDE_DIR=/usr/include \
+ -DJSON_INCLUDE_DIR=/usr/include \
-DGLTF_SUPPORT=On \
-DSWIG_EXECUTABLE="/usr/bin/swig" \
../cmake/
@@ -51,16 +59,23 @@ build() {
}
package() {
+ # Install IfcOpenShell
cd "${srcdir}/IfcOpenShell/build"
make DESTDIR="${pkgdir}" install
+ # Install license file
cd "${srcdir}/IfcOpenShell"
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
- mkdir -p "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib
- cp -rf "${srcdir}"/IfcOpenShell/src/ifcblender/* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib
- cp -rf "${srcdir}"/IfcOpenShell/src/ifcopenshell-python/* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib/io_import_scene_ifc
- cp -f "${srcdir}"/IfcOpenShell/build/ifcwrap/*ifcopenshell_wrapper* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib/io_import_scene_ifc/ifcopenshell
+ # Install blender bim addon
+ mkdir -p "${pkgdir}/usr/share/blender/${_blenderver}/scripts/addons"
+ cd "${pkgdir}/usr/share/blender/${_blenderver}/scripts/addons"
+ cp -rf "${srcdir}/IfcOpenShell/src/ifcblenderexport/blenderbim" "./"
+ cd blenderbim/libs/site/packages
+ cp -rf "${srcdir}/IfcOpenShell/src/ifcclash/." "./"
+ cp -rf "${srcdir}/IfcOpenShell/src/ifcdiff/." "./"
+ python -O -m compileall "${pkgdir}/usr/share/blender/${_blenderver}/scripts/addons/blenderbim"
+ chmod -R a+rwX "${pkgdir}/usr/share/blender/${_blenderver}/scripts/addons/blenderbim/bim/data"
}
md5sums=('SKIP')