summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyril@biminsight.ch2020-07-10 10:35:35 +0200
committercyril@biminsight.ch2020-07-10 10:35:35 +0200
commitf457b09ce0a8e302e0ad3c1535a1779f6fadcd46 (patch)
tree71090c5a1309b24a6b004af27849a4480e03e64a
parent6367b128ab6cc6b9349a2bc23273cac6355b5154 (diff)
downloadaur-f457b09ce0a8e302e0ad3c1535a1779f6fadcd46.tar.gz
Updated to v0.6.0 which is the new master branch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD48
2 files changed, 19 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 914bd20f8707..54ad0db736bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ifcopenshell-git
pkgdesc = Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version.
- pkgver = 0.5.0rc0.r17.g8625aab5
+ pkgver = 0.6.0b0.r875.g607e5067
pkgrel = 1
url = http://ifcopenshell.org/
arch = x86_64
@@ -19,7 +19,7 @@ pkgbase = ifcopenshell-git
provides = IfcConvert
provides = IfcGeomServer
conflicts = ifcopenshell
- source = IfcOpenShell::git://github.com/IfcOpenShell/IfcOpenShell.git
+ source = git+https://github.com/IfcOpenShell/IfcOpenShell.git
md5sums = SKIP
pkgname = ifcopenshell-git
diff --git a/PKGBUILD b/PKGBUILD
index bc3c1f394ae9..bd6e25a764d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
+# Maintainer: Cyril Waechter <cyril[at]biminsight[dot]ch>
+# Contributor: mickele <mimocciola[at]yahoo[dot]com>
pkgname=ifcopenshell-git
-pkgver=0.5.0rc0.r17.g8625aab5
+pkgver=0.6.0b0.r875.g607e5067
pkgrel=1
pkgdesc="Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version."
arch=('x86_64' 'i686')
@@ -12,22 +14,11 @@ provides=('ifcopenshell' 'IfcBlender' 'IfcConvert' 'IfcGeomServer')
conflicts=('ifcopenshell')
replaces=()
backup=()
-source=('IfcOpenShell::git://github.com/IfcOpenShell/IfcOpenShell.git')
-_blenderver=2.76
+source=("git+https://github.com/IfcOpenShell/IfcOpenShell.git")
+_blenderver=2.83
prepare(){
cd "${srcdir}/IfcOpenShell"
-
- sed -e 's|#include "SvgSerializer.h"|#include "SvgSerializer.h"\n#include <Standard_Version.hxx>|' -i src/ifcconvert/SvgSerializer.cpp
-
- sed -e 's|\t#include "../ifcgeom/IfcGeom.h"|\t// #include "../ifcgeom/IfcGeom.h"|' -i src/ifcwrap/IfcPython.i
- sed -e 's|\t#include "../ifcgeom/IfcGeomIterator.h"|\t#include "../ifcgeom/IfcGeomIterator.h"\n\t#include "../ifcgeom/IfcGeom.h"|' -i src/ifcwrap/IfcPython.i
-
- sed -e "s|FIND_PACKAGE(Boost REQUIRED COMPONENTS system program_options regex thread date_time)|FIND_PACKAGE(Boost REQUIRED COMPONENTS system program_options regex thread date_time)\nADD_DEFINITIONS(-DBOOST_OPTIONAL_USE_OLD_DEFINITION_OF_NONE)|" -i cmake/CMakeLists.txt
-
- sed -e "s|boost::shared_ptr<Representation::Triangulation<P>>|boost::shared_ptr<Representation::Triangulation<P> >|" -i src/ifcgeom/IfcGeomElement.h
-
- sed -e "s|#include <iomanip>|#include <iomanip>\n#include <unicode/unistr.h>|" -i src/ifcparse/IfcCharacterDecoder.cpp
}
pkgver() {
@@ -42,25 +33,20 @@ pkgver() {
build() {
cd "${srcdir}/IfcOpenShell"
- if [ -d "build" ]; then
- rm -rf build
- fi
mkdir -p build
- cd build
+ cd "${srcdir}/IfcOpenShell/build"
local _pythonver=$(python --version >&1)
- # -DBUILD_IFCPYTHON=OFF \
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_CXX_STANDARD=11 \
- -DOCC_INCLUDE_DIR=/usr/include/opencascade \
+
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DOCC_INCLUDE_DIR=/usr/include/opencascade \
-DOCC_LIBRARY_DIR=/usr/lib \
- -DOPENCOLLADA_INCLUDE_DIR=/usr/include/opencollada \
- -DOPENCOLLADA_LIBRARY_DIR=/usr/lib/opencollada \
- -DICU_INCLUDE_DIR=/usr/include/unicode \
- -DICU_LIBRARY_DIR=/usr/lib \
- -DPYTHON_INCLUDE_DIR=/usr/include/python${_pythonver:7:3} \
- -DPYTHON_LIBRARY=/usr/lib64/libpython${_pythonver:7:3}.so \
- -DSWIG_EXECUTABLE=/usr/bin/swig \
- ../cmake
+ -DLIBXML2_INCLUDE_DIR=/usr/include/libxml2 \
+ -DLIBXML2_LIBRARIES="/usr/lib/libxml2.so.2" \
+ -DJSON_INCLUDE_DIR=/usr/include \
+ -DGLTF_SUPPORT=On \
+ -DSWIG_EXECUTABLE="/usr/bin/swig" \
+ ../cmake/
make
}
@@ -69,7 +55,7 @@ package() {
make DESTDIR="${pkgdir}" install
cd "${srcdir}/IfcOpenShell"
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
mkdir -p "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib
cp -rf "${srcdir}"/IfcOpenShell/src/ifcblender/* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib