summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrás Wacha2016-11-09 08:48:15 +0100
committerAndrás Wacha2016-11-09 08:48:15 +0100
commitddd52f8ad73860e192bf30386ffbb8099a646428 (patch)
tree3a640e42de07965af317dcd38e18b8951fcd1c26
downloadaur-ddd52f8ad73860e192bf30386ffbb8099a646428.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD41
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25444f5f8d2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ifeffit
+ pkgdesc = XAFS analysis program
+ pkgver = 1.2.final
+ pkgrel = 2
+ url = http://cars9.uchicago.edu/ifeffit/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-fortran
+ depends = pgplot
+ source = https://github.com/newville/ifeffit/archive/1.2.final.tar.gz
+ md5sums = 8708de3ea387cd0a47c7a1a4b5cf8e8e
+
+pkgname = ifeffit
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd6ad2726234
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.tar.gz
+*.pkg.tar.xz
+*~
+*.log \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..562aad0119a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: András WACHA <awacha@gmail.com>
+pkgname=ifeffit
+pkgver=1.2.final
+pkgrel=2
+pkgdesc="XAFS analysis program"
+arch=('i686' 'x86_64')
+url="http://cars9.uchicago.edu/ifeffit/"
+license=('GPL')
+depends=('pgplot')
+makedepends=('gcc-fortran')
+source=("https://github.com/newville/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('8708de3ea387cd0a47c7a1a4b5cf8e8e')
+
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr --with-pgplot=/usr/lib --with-pgplot-link="-lpgplot"
+ make
+}
+
+#check() {
+# cd "$pkgname-$pkgver"
+# make -k check
+#}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ mv "${pkgdir}/usr/share/ifeffit/libifeffit.so" "${pkgdir}/usr/lib/"
+ mv "${pkgdir}/usr/bin/ifeffit" "${pkgdir}/usr/bin/ifeffit.bin"
+ cat >"${pkgdir}/usr/bin/ifeffit" <<EOF
+#!/bin/sh
+
+PGPLOT_FONT=/usr/lib/grfont.dat /usr/bin/ifeffit.bin \$*
+EOF
+ chmod +x "${pkgdir}/usr/bin/ifeffit"
+}