summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzocker-1602020-07-01 21:48:40 +0200
committerzocker-1602020-07-01 21:48:40 +0200
commit26aae3833844a5237e78f1ad5fbad7125e7e08a9 (patch)
tree8925c257fe43ae2f9c32e639d32f1586caf67f62
downloadaur-26aae3833844a5237e78f1ad5fbad7125e7e08a9.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84d1abed19fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ifm-git
+ pkgdesc = A language and a program for keeping track of your progress through an Interactive Fiction game.
+ pkgver = 5.5
+ pkgrel = 1
+ url = https://ifm.readthedocs.io/en/latest/intro.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = tk
+ makedepends = help2man
+ depends = tk
+ depends = perl
+ conflicts = ifm
+ options = docs
+ source = https://github.com/zocker-160/ifm/archive/v5.5.tar.gz
+ sha256sums = eb7a038864fad62ccc4cfe8f5f12aac233f5602fdb3957e8070a27b937718b3e
+
+pkgname = ifm-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c5b9a02da18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: zocker_160 <zocker1600 at posteo dot net>
+# Contributor: Brian Schubert <bewschubert@gmail.com>
+
+pkgname=ifm-git
+_pkgname=ifm
+pkgver=5.5
+pkgrel=1
+pkgdesc="A language and a program for keeping track of your progress through an Interactive Fiction game."
+arch=('i686' 'x86_64')
+url="https://ifm.readthedocs.io/en/latest/intro.html"
+license=('GPL2')
+depends=('tk' 'perl')
+makedepends=('tk' 'help2man')
+conflicts=('ifm')
+source=(https://github.com/zocker-160/ifm/archive/v$pkgver.tar.gz)
+sha256sums=('eb7a038864fad62ccc4cfe8f5f12aac233f5602fdb3957e8070a27b937718b3e')
+options=('docs')
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+
+ chmod +x ./autogen.sh
+ ./autogen.sh
+
+ export CPPFLAGS=-D_GNU_SOURCE
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ make DESTDIR=$pkgdir docdir=$pkgdir/usr/share/doc install
+}