summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Jones2018-04-30 11:05:57 -0400
committerNathan Jones2018-04-30 11:05:57 -0400
commit4fb7e9a00485ed635fb2f0904ed109339fa08db9 (patch)
treecefa7a4473c1e83cc0039320850b6e1cb4e51738
downloadaur-4fb7e9a00485ed635fb2f0904ed109339fa08db9.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--0001-a.patch49
-rw-r--r--PKGBUILD31
-rw-r--r--ifstat.install3
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d7948d88198
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ifstat
+ pkgdesc = A tool to report network interfaces bandwith just like vmstat/iostat do for other system counters
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://gael.roualland.free.fr/ifstat/
+ install = ifstat.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ source = http://gael.roualland.free.fr/ifstat/ifstat-1.1.tar.gz
+ source = 0001-a.patch
+ md5sums = b655642c33a626cfe976792fbcd9b6e1
+ md5sums = 4d299f8c7896b0c5046867070137ad09
+
+pkgname = ifstat
+
diff --git a/0001-a.patch b/0001-a.patch
new file mode 100644
index 000000000000..7f7de4a0f9f9
--- /dev/null
+++ b/0001-a.patch
@@ -0,0 +1,49 @@
+From 83072da5bd5aa64c243d4dbdd10c788714701939 Mon Sep 17 00:00:00 2001
+From: Nathan Jones <nathanj439@gmail.com>
+Date: Mon, 30 Apr 2018 10:47:16 -0400
+Subject: [PATCH] a
+
+---
+ Makefile.in | 6 +++---
+ ifstat.1 => ifstat2.1 | 0
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+ rename ifstat.1 => ifstat2.1 (100%)
+
+diff --git a/Makefile.in b/Makefile.in
+index 486fe3e..2a88c21 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -20,7 +20,7 @@ LIBSRCS = drivers.c data.c @SNMPSRC@
+ SRCS = ifstat.c $(LIBSRCS)
+ OBJS = ${SRCS:.c=.o}
+ LIBOBJS = ${LIBSRCS:.c=.o}
+-TARGET = ifstat
++TARGET = ifstat2
+ LIBTARGET = libifstat.a
+ TARGETS = $(TARGET) @LIBTARGET@
+
+@@ -45,7 +45,7 @@ distclean: clean
+ $(RM) config.h config.cache config.log config.status Makefile libifstat-config
+
+ maintainer-clean: distclean
+- $(RM) configure config.h.in ifstat.1
++ $(RM) configure config.h.in ifstat2.1
+
+ ${srcdir}/configure: configure.in
+ cd ${srcdir} && autoconf
+@@ -68,7 +68,7 @@ install-$(TARGET): $(TARGET)
+ $(INSTALL) -d -m 755 $(bindir)
+ $(INSTALL) -s -m 755 $(TARGET) $(bindir)/$(TARGET)
+ $(INSTALL) -d -m 755 $(mandir)/man1
+- $(INSTALL) -m 644 ifstat.1 $(mandir)/man1/ifstat.1
++ $(INSTALL) -m 644 ifstat2.1 $(mandir)/man1/ifstat2.1
+
+ install-$(LIBTARGET): $(LIBTARGET) libifstat-config
+ $(INSTALL) -d -m 755 $(bindir)
+diff --git a/ifstat.1 b/ifstat2.1
+similarity index 100%
+rename from ifstat.1
+rename to ifstat2.1
+--
+2.16.2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d78bc98cc649
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Nathan Jones <nathanj439@gmail.com>
+pkgname=ifstat
+pkgver=1.1
+pkgrel=1
+pkgdesc="A tool to report network interfaces bandwith just like vmstat/iostat do for other system counters"
+arch=('i686' 'x86_64')
+url="http://gael.roualland.free.fr/ifstat/"
+license=('BSD')
+install=ifstat.install
+source=("http://gael.roualland.free.fr/ifstat/ifstat-$pkgver.tar.gz"
+ "0001-a.patch")
+md5sums=('b655642c33a626cfe976792fbcd9b6e1'
+ '4d299f8c7896b0c5046867070137ad09')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/../0001-a.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr --without-snmp
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 ifstat2 $pkgdir/usr/bin/ifstat2
+ install -Dm644 ifstat2.1 $pkgdir/usr/share/man/man1/ifstat2.1
+}
diff --git a/ifstat.install b/ifstat.install
new file mode 100644
index 000000000000..0ba4543ade63
--- /dev/null
+++ b/ifstat.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "Note the command is named 'ifstat2' since 'ifstat' lives in the iproute2 package."
+}