summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12016-05-11 01:54:37 +0800
committerChocobo12016-05-11 02:07:32 +0800
commitefbf1fd353350537d5948f6666c0c0bb64b2fa53 (patch)
tree637ded510e4c3768c71741285bfab9991bc68e27
parenteb27a048f0a5e968d216fb57446f9767362573c8 (diff)
downloadaur-efbf1fd353350537d5948f6666c0c0bb64b2fa53.tar.gz
Add patch fix compilation
-rw-r--r--PKGBUILD7
-rw-r--r--fix-compile.patch10
2 files changed, 15 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f72dd988918..06c8c011b9fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,13 +10,16 @@ license=('GPL')
depends=('linux>=2.6.30')
makedepends=('linux-headers>=2.6.30')
install=$pkgname.install
-source=("$pkgname-$pkgver-src.tar.gz::https://sourceforge.net/projects/e1000/files/igb%20stable/5.3.4.4/$pkgname-$pkgver.tar.gz/download")
-sha256sums=('556708dbb8c891e1a23c1bd280b6bd1c28ccee061a4a3da8220dd8daa74c103f')
+source=("$pkgname-$pkgver-src.tar.gz::https://sourceforge.net/projects/e1000/files/igb%20stable/5.3.4.4/$pkgname-$pkgver.tar.gz/download"
+ 'fix-compile.patch')
+sha256sums=('556708dbb8c891e1a23c1bd280b6bd1c28ccee061a4a3da8220dd8daa74c103f'
+ '1c894085cf6a866ac720deefc5dc516bd7f308667ad159501bf2cb7ff5eb5317')
build() {
cd "$srcdir/$pkgname-$pkgver/src"
+ patch -p1 -i "$srcdir/fix-compile.patch"
make
}
diff --git a/fix-compile.patch b/fix-compile.patch
new file mode 100644
index 000000000000..5ec880ab2d13
--- /dev/null
+++ b/fix-compile.patch
@@ -0,0 +1,10 @@
+--- a/igb.h
++++ b/igb.h
+@@ -72,7 +72,6 @@ struct igb_adapter;
+ #ifdef HAVE_PTP_1588_CLOCK
+ #ifdef HAVE_INCLUDE_LINUX_TIMECOUNTER_H
+ #include <linux/timecounter.h>
+-#else
+ #include <linux/clocksource.h>
+ #endif /* HAVE_INCLUDE_TIMECOUNTER_H */
+ #include <linux/net_tstamp.h>