summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoriboyperson2019-03-17 12:54:33 -0700
committeriboyperson2019-03-17 12:54:33 -0700
commit8f01377c918e3e710edabdf517937e3a46977aa6 (patch)
tree7fa44d5fddc7db6e73007c5e8c53f9a60fe9dc2e
downloadaur-8f01377c918e3e710edabdf517937e3a46977aa6.tar.gz
updpkg: 2.6.2-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD26
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fd4b1324cf4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = igdm-bin
+ pkgdesc = Desktop application for Instagram DMs
+ pkgver = 2.6.2
+ pkgrel = 1
+ url = https://github.com/ifedapoolarewaju/igdm
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = glibc
+ depends = gtk3
+ depends = nss
+ provides = igdm
+ conflicts = igdm
+ source = https://raw.githubusercontent.com/ifedapoolarewaju/igdm/master/LICENSE
+ sha256sums = 1777c54d2f39e230ba87a3c793117de156a57fcb38043f16f7a6baadc80b1421
+ source_x86_64 = igdm-bin-2.6.2-x86_64.deb::https://github.com/ifedapoolarewaju/igdm/releases/download/v2.6.2/IGdm_2.6.2_amd64.deb
+ sha256sums_x86_64 = e17fb011dcc47fcd6aa5e1100c7306704eede5366f2ffdaaabca927637f9df92
+ source_i686 = igdm-bin-2.6.2-i686.deb::https://github.com/ifedapoolarewaju/igdm/releases/download/v2.6.2/IGdm_2.6.2_i386.deb
+ sha256sums_i686 = fe3b49fe584e8239cdb35cd91ff4e604567a7343d10800b9369a8c74844de1d8
+
+pkgname = igdm-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b1778402cff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Thomas Quillan <tjquillan@gmail.com>
+pkgname=igdm-bin
+pkgver=2.6.2
+pkgrel=1
+pkgdesc="Desktop application for Instagram DMs"
+arch=('x86_64' 'i686')
+url="https://github.com/ifedapoolarewaju/igdm"
+license=('MIT')
+groups=()
+depends=('glibc' 'gtk3' 'nss')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=('igdm')
+conflicts=('igdm')
+source=("https://raw.githubusercontent.com/ifedapoolarewaju/igdm/master/LICENSE")
+source_x86_64=("${pkgname}-${pkgver}-x86_64.deb::https://github.com/ifedapoolarewaju/igdm/releases/download/v${pkgver}/IGdm_${pkgver}_amd64.deb")
+source_i686=("${pkgname}-${pkgver}-i686.deb::https://github.com/ifedapoolarewaju/igdm/releases/download/v${pkgver}/IGdm_${pkgver}_i386.deb")
+sha256sums=('1777c54d2f39e230ba87a3c793117de156a57fcb38043f16f7a6baadc80b1421')
+sha256sums_x86_64=('e17fb011dcc47fcd6aa5e1100c7306704eede5366f2ffdaaabca927637f9df92')
+sha256sums_i686=('fe3b49fe584e8239cdb35cd91ff4e604567a7343d10800b9369a8c74844de1d8')
+
+package() {
+ tar xf "data.tar.xz" -C "${pkgdir}"
+ install -Dm644 "${srcdir}"/LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}