summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmmon Smith2018-02-28 18:22:29 -0800
committerAmmon Smith2018-02-28 18:22:29 -0800
commit4c35d61e2e45e712b1d3b12f9d6a23fbb88355af (patch)
tree2536ca52c7d5fbd5432695a79a669d09ca58701a
downloadaur-4c35d61e2e45e712b1d3b12f9d6a23fbb88355af.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--iget-wrapper.sh2
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..951cee92b0ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = iget-git
+ pkgdesc = A command-line program to give you the number of days until or since certain events.
+ pkgver = 1.0.1_1_g53cd567.53cd567
+ pkgrel = 1
+ url = https://gitlab.com/ammongit/iget
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-setuptools
+ provides = iget
+ conflicts = iget
+ source = git+https://gitlab.com/ammongit/iget.git
+ source = iget-wrapper.sh
+ sha256sums = SKIP
+ sha256sums = 184c33840db24b394e76d143534a9f80b8a355c31f0635287286e0791704c1ee
+
+pkgname = iget-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14052eba5c62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Ammon Smith <ammon.i.smith@gmail.com>
+
+pkgname="iget-git"
+pkgver=1.0.1_1_g53cd567.53cd567
+pkgrel=1
+pkgdesc='A command-line program to give you the number of days until or since certain events.'
+arch=('any')
+url="https://gitlab.com/ammongit/${pkgname%-git}"
+license=('MIT')
+depends=('python' 'python-setuptools')
+makedepends=('git')
+optdepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+options=()
+source=("git+https://gitlab.com/ammongit/${pkgname%-git}.git"
+ 'iget-wrapper.sh')
+sha256sums=('SKIP'
+ '184c33840db24b394e76d143534a9f80b8a355c31f0635287286e0791704c1ee')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ local _ver="$(git describe --tags | sed 's/-/_/g')"
+ printf '%s.%s' "${_ver:1}" "$(git describe --always)"
+}
+
+package() {
+ cd "$srcdir"
+ install -D -m755 'iget-wrapper.sh' "$pkgdir/usr/bin/iget"
+
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: set ft=sh noet:
diff --git a/iget-wrapper.sh b/iget-wrapper.sh
new file mode 100644
index 000000000000..17bb73572c49
--- /dev/null
+++ b/iget-wrapper.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec python3 -m iget "$@"