summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortechknowlogick2021-07-28 00:04:51 -0400
committertechknowlogick2021-07-28 00:04:51 -0400
commit50b0cfd67889f6e80e880ce38b4401f60da1a132 (patch)
tree0f3271713783cbf4b7d6331436391b48db6c23f0
parentcb999178b2d76874dec9bf712b26e572f2ebddf6 (diff)
downloadaur-50b0cfd67889f6e80e880ce38b4401f60da1a132.tar.gz
ignite 0.10.0-1
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68bda1670d53..b7631e58812b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: techknowlogick <techknowlogick at gitea dot io>
pkgname=ignite
pkgver=0.10.0
-pkgrel=0
+pkgrel=1
pkgdesc="Weaveworks Ignite, combines Firecracker MicroVMs with Docker/OCI images to unify containers and VMs."
arch=('x86_64' 'aarch64')
url="https://github.com/weaveworks/ignite"
@@ -19,6 +19,7 @@ sha256sums=('422331d1f507c28057e2b9a7a3cbd21ba8239e5830ea0f691b6408dbc6f223d1'
build() {
cd "$pkgname-$pkgver"
# build assumes git repo, but we're building from tarball, so we need to set state to clean
+ sed -i hack/ldflags.sh -e "s/IGNITE_GIT_TREE_STATE..dirty/IGNITE_GIT_TREE_STATE\=\"clean/i"
go build -mod=vendor -ldflags "$(IGNITE_GIT_VERSION=v${pkgver} ./hack/ldflags.sh)" -o ignite ./cmd/ignite
go build -mod=vendor -ldflags "$(IGNITE_GIT_VERSION=v${pkgver} ./hack/ldflags.sh)" -o ignited ./cmd/ignited
}