summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Rakowski2018-02-24 10:56:05 +0100
committerTim Rakowski2018-02-24 10:56:05 +0100
commit236759f5524915ace0da4b9d5c3d5465c1646b0c (patch)
treeb5ea0c78842d91f9e92e2e71e9592364e7e65039
downloadaur-236759f5524915ace0da4b9d5c3d5465c1646b0c.tar.gz
Initial commit: version 1.0.1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD50
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97a4847667dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sat Feb 24 09:55:45 UTC 2018
+pkgbase = ignition-common
+ pkgdesc = A collection of useful classes and functions for handling many command tasks. This includes parsing 3D mesh files, managing console output, and using PID controllers.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://ignitionrobotics.org/libs/common
+ arch = any
+ groups = development
+ license = Apache
+ makedepends = ignition-cmake
+ makedepends = util-linux
+ depends = ignition-math
+ depends = tinyxml2
+ depends = freeimage
+ depends = libutil-linux
+ depends = gts
+ depends = ffmpeg
+ source = https://bitbucket.org/ignitionrobotics/ign-common/get/ignition-common_1.0.1.tar.bz2
+ sha256sums = 847b60e0e05a49220607e625546ce032be053bec3da2fe4efbf76d6e0382b5c2
+
+pkgname = ignition-common
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..080ab461c873
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: Tim Rakowski <tim.rakowski@gmail.com>
+pkgname=ignition-common
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A collection of useful classes and functions for handling many command tasks. This includes parsing 3D mesh files, managing console output, and using PID controllers."
+arch=('any')
+url="http://ignitionrobotics.org/libs/common"
+license=('Apache')
+groups=('development')
+makedepends=('ignition-cmake' 'util-linux')
+depends=('ignition-math' 'tinyxml2' 'freeimage' 'libutil-linux' 'gts' 'ffmpeg')
+optdepends=()
+conflicts=()
+source=("https://bitbucket.org/ignitionrobotics/ign-common/get/${pkgname}_${pkgver}.tar.bz2")
+sha256sums=('847b60e0e05a49220607e625546ce032be053bec3da2fe4efbf76d6e0382b5c2')
+
+_dir="ignitionrobotics-ign-common-21fe175fe91c"
+
+build() {
+ cd "$srcdir/$_dir"
+
+ mkdir -p build
+ cd build
+
+ # Configure build
+ cmake .. -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DBUILD_TESTING:BOOL=False
+
+ # Compile
+ make
+}
+
+check() {
+ cd "$srcdir/$_dir/build"
+
+ cmake .. -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DBUILD_TESTING:BOOL=True
+
+ make
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dir/build"
+ make DESTDIR="$pkgdir/" install
+}