summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-12-26 13:11:25 -0500
committeracxz2020-12-26 13:11:25 -0500
commit1af54cfafd6e4c441959229bed54aca45987b9ce (patch)
tree8f9c0b4169cce6699ec15e5087e99fd03db1404b
parentfe13595ad3b0df667bf867c033b1871366e1291c (diff)
downloadaur-1af54cfafd6e4c441959229bed54aca45987b9ce.tar.gz
fix install prefix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05204fa8799d..017aed8acb00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ignition-gui
pkgdesc = Builds on top of Qt to provide widgets which are useful when developing robotics applications, such as a 3D view, plots, dashboard, etc, and can be used together in a convenient unified interface.
pkgver = 4.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://ignitionrobotics.org/libs/gui
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 222ba3b1d793..38a0c58b79ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ignition-gui
pkgver=4.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Builds on top of Qt to provide widgets which are useful when developing
robotics applications, such as a 3D view, plots, dashboard, etc, and can be used
together in a convenient unified interface."
@@ -35,7 +35,7 @@ build() {
# Configure build
cmake .. -DCMAKE_BUILD_TYPE="Release" \
- -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DBUILD_TESTING=OFF
@@ -45,5 +45,5 @@ build() {
package() {
cd "$srcdir/$_dir/build"
- make install
+ make DESTDIR="${pkgdir}/" install
}