summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-12-30 14:12:02 -0500
committeracxz2020-12-30 14:12:02 -0500
commit85a0365bd10bfe727bf3a31e67cdd85d28adfe22 (patch)
tree0fd69038bd9f3942f13fe801e411718d0220d0a7
parente38d535217b97b7907f396082997695f5ac2b674 (diff)
downloadaur-85a0365bd10bfe727bf3a31e67cdd85d28adfe22.tar.gz
add entity patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad2915ff62c6..0c5017c79ad0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ignition-physics
pkgdesc = Abstract physics interface designed to support simulation and rapid development of robot applications.
pkgver = 3.1.0
- pkgrel = 3
+ pkgrel = 4
url = https://ignitionrobotics.org/libs/physics
arch = x86_64
license = Apache
@@ -14,7 +14,9 @@ pkgbase = ignition-physics
depends = libdart
depends = sdformat
source = ignition-physics-3.1.0.tar.gz::https://github.com/ignitionrobotics/ign-physics/archive/ignition-physics3_3.1.0.tar.gz
+ source = entity.patch::https://patch-diff.githubusercontent.com/raw/ignitionrobotics/ign-physics/pull/185.patch
sha256sums = b8e5460d2808e20237b2ee0a6a6b7613b56412f5f6e2a5e153e48e8faae8ab77
+ sha256sums = SKIP
pkgname = ignition-physics
diff --git a/PKGBUILD b/PKGBUILD
index afe9c4ed9e9d..5efe6b78bdd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ignition-physics
pkgver=3.1.0
-pkgrel=3
+pkgrel=4
pkgdesc="Abstract physics interface designed to support simulation and rapid
development of robot applications."
arch=('x86_64')
@@ -11,30 +11,33 @@ license=('Apache')
depends=('ignition-cmake' 'ignition-math' 'ignition-plugin' 'ignition-common'
'libdart' 'sdformat')
makedepends=('cmake' 'clang')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ignitionrobotics/ign-physics/archive/${pkgname}3_${pkgver}.tar.gz")
-sha256sums=('b8e5460d2808e20237b2ee0a6a6b7613b56412f5f6e2a5e153e48e8faae8ab77')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ignitionrobotics/ign-physics/archive/${pkgname}3_${pkgver}.tar.gz"
+ "entity.patch::https://patch-diff.githubusercontent.com/raw/ignitionrobotics/ign-physics/pull/185.patch")
+sha256sums=('b8e5460d2808e20237b2ee0a6a6b7613b56412f5f6e2a5e153e48e8faae8ab77'
+ 'SKIP')
_dir="ign-physics-${pkgname}3_${pkgver}"
+prepare() {
+ cd "$srcdir/$_dir"
+ patch --forward --strip=1 --input="${srcdir}/entity.patch"
+}
+
build() {
cd "$srcdir/$_dir"
mkdir -p build
cd build
- # Configure build
cmake .. -DCMAKE_BUILD_TYPE="Release" \
- -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
- -DCMAKE_C_COMPILER=clang \
- -DCMAKE_CXX_COMPILER=clang++ \
-DBUILD_TESTING=OFF
- # Compile
make
}
package() {
cd "$srcdir/$_dir/build"
- make install
+ make DESTDIR="${pkgdir}/" install
}