summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-06-29 14:49:28 -0400
committeracxz2019-06-29 14:49:28 -0400
commitcd378f030353c70448a2d6beaa2f024f5d58a019 (patch)
tree97be3e8ac8229d86b1ab9e71046a41ad8cce4f06
downloadaur-cd378f030353c70448a2d6beaa2f024f5d58a019.tar.gz
Created v4 of ignition-transport
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c033f3cb381b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ignition-transport-4
+ pkgdesc = The transport library combines ZeroMQ with Protobufs to create a fast and efficient message passing system. Asynchronous message publication and subscription is provided along with service calls and discovery.
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = http://ignitionrobotics.org/libs/transport
+ arch = i686
+ arch = x86_64
+ groups = development
+ license = Apache
+ makedepends = ignition-cmake=0
+ makedepends = util-linux
+ depends = protobuf
+ depends = protobuf-c
+ depends = zeromq
+ depends = ignition-msgs=1
+ depends = ignition-tools
+ depends = libutil-linux
+ provides = ignition-transport=4
+ source = https://bitbucket.org/ignitionrobotics/ign-transport/get/ignition-transport4_4.0.0.tar.bz2
+ sha256sums = 72d1e603b9c0ffb54b088f9e42fc27f9e5971a4dac076351b592cb3938ce96d1
+
+pkgname = ignition-transport-4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..965794482f39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+pkgname=ignition-transport-4
+pkgver=4.0.0
+pkgrel=1
+pkgdesc="The transport library combines ZeroMQ with Protobufs to create a fast and efficient message passing system. Asynchronous message publication and subscription is provided along with service calls and discovery."
+arch=('i686' 'x86_64')
+url="http://ignitionrobotics.org/libs/transport"
+license=('Apache')
+groups=('development')
+depends=('protobuf' 'protobuf-c' 'zeromq' 'ignition-msgs=1' 'ignition-tools' 'libutil-linux')
+makedepends=('ignition-cmake=0' 'util-linux')
+optdepends=()
+provides=('ignition-transport=4')
+_name="ignition-transport4"
+source=("https://bitbucket.org/ignitionrobotics/ign-transport/get/${_name}_${pkgver}.tar.bz2")
+sha256sums=('72d1e603b9c0ffb54b088f9e42fc27f9e5971a4dac076351b592cb3938ce96d1')
+
+_dir="ignitionrobotics-ign-transport-add6058e5b8c"
+
+build() {
+ cd "${srcdir}/${_dir}"
+ mkdir -p build && cd build
+
+ cmake .. -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DBUILD_TESTING=Off
+ make -j4
+}
+
+check() {
+ cd "${srcdir}/${_dir}/build"
+
+ cmake .. -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DBUILD_TESTING=On
+ make -j4
+ make test
+}
+
+package() {
+ cd "${srcdir}/${_dir}/build"
+ make DESTDIR="${pkgdir}/" install
+}