summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commitaa49116c803582d548aff3c9d778733ad3df4c9e (patch)
treeb6905c52a8c3c4ac02b0dc8077bcffb15891a6d2
downloadaur-aa49116c803582d548aff3c9d778733ad3df4c9e.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD44
-rw-r--r--ignuit.desktop9
-rw-r--r--ignuit.install28
4 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e18c96b00b42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = ignuit
+ pkgdesc = A memorization aid based on the Leitner flashcard system
+ pkgver = 2.20.0
+ pkgrel = 1
+ url = http://homepages.ihug.co.nz/~trmusson/programs.html#ignuit
+ install = ignuit.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gconf
+ depends = gnome-doc-utils
+ depends = gstreamer0.10-base
+ depends = hicolor-icon-theme
+ depends = intltool
+ depends = libgnomeui
+ depends = libglade
+ depends = libxslt
+ source = http://homepages.ihug.co.nz/~trmusson/stuff/ignuit-2.20.0.tar.gz
+ source = ignuit.desktop
+ source = http://homepages.ihug.co.nz/~trmusson/ignuit/countries_and_capitals-en.xml
+ source = http://homepages.ihug.co.nz/~trmusson/ignuit/numbers_days_months-en_ru-without_audio.xml
+ sha256sums = 5dc75cef0707677421c272c430cebf5c3730cbcfaeba6428fe14f6bd085d3630
+ sha256sums = 89c160391f5d39b47a9b0ce6dc28080d96acebee356d1a7372a18a8511fea935
+ sha256sums = 60f82b36b02bfa504f5a3f9f0c1c1d96856f675470ecd5fd56dbf4c185e381e7
+ sha256sums = 77523badda6c08af9728f1f45defc04c1c609154cdb285088228f96dc1930191
+
+pkgname = ignuit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2830f2347c77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=ignuit
+pkgver=2.20.0
+pkgrel=1
+pkgdesc="A memorization aid based on the Leitner flashcard system"
+arch=('i686' 'x86_64')
+url="http://homepages.ihug.co.nz/~trmusson/programs.html#ignuit"
+license=('GPL')
+depends=('gconf' 'gnome-doc-utils' 'gstreamer0.10-base' 'hicolor-icon-theme' 'intltool' 'libgnomeui' 'libglade' 'libxslt')
+install=$pkgname.install
+source=(http://homepages.ihug.co.nz/~trmusson/stuff/$pkgname-$pkgver.tar.gz \
+ $pkgname.desktop \
+ http://homepages.ihug.co.nz/~trmusson/$pkgname/countries_and_capitals-en.xml \
+ http://homepages.ihug.co.nz/~trmusson/$pkgname/numbers_days_months-en_ru-without_audio.xml)
+sha256sums=('5dc75cef0707677421c272c430cebf5c3730cbcfaeba6428fe14f6bd085d3630'
+ '89c160391f5d39b47a9b0ce6dc28080d96acebee356d1a7372a18a8511fea935'
+ '60f82b36b02bfa504f5a3f9f0c1c1d96856f675470ecd5fd56dbf4c185e381e7'
+ '77523badda6c08af9728f1f45defc04c1c609154cdb285088228f96dc1930191')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ ./configure --prefix=/usr --with-gconf-schema-file-dir=/etc/gconf/schemas
+ make
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ make DESTDIR=${pkgdir} install
+
+ rm -r ${pkgdir}/usr/share/locale
+
+#example files
+ install -D -m644 ${srcdir}/countries_and_capitals-en.xml \
+ ${pkgdir}/usr/share/$pkgname/examples/countries_and_capitals-en.xml
+ install -D -m644 ${srcdir}/numbers_days_months-en_ru-without_audio.xml \
+ ${pkgdir}/usr/share/$pkgname/examples/numbers_days_months-en_ru-without_audio.xml
+
+#.desktop file
+ install -D -m644 ${srcdir}/$pkgname.desktop \
+ ${pkgdir}/usr/share/applications/$pkgname.desktop
+}
diff --git a/ignuit.desktop b/ignuit.desktop
new file mode 100644
index 000000000000..4015505d0010
--- /dev/null
+++ b/ignuit.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Ignuit
+GenericName=ignuit
+Exec=ignuit
+Icon=ignuit
+Type=Application
+Comment=A memorization aid based on the Leitner flashcard system
+Terminal=false
+Categories=Education;
diff --git a/ignuit.install b/ignuit.install
new file mode 100644
index 000000000000..483c8f28f0cb
--- /dev/null
+++ b/ignuit.install
@@ -0,0 +1,28 @@
+infodir=/usr/share/info
+filelist=(ignuit.info)
+
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_remove() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}