summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2019-01-02 17:40:03 +1100
committerStephen Gregoratto2019-01-02 17:40:03 +1100
commit7d52147bedd098f2fe2c285eabdfb89a7f5ced4d (patch)
treedcc6234df5a7017f29807ee40c453cc5a4f77323
downloadaur-7d52147bedd098f2fe2c285eabdfb89a7f5ced4d.tar.gz
Initial Version.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--igor.patch49
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdb6ab2162c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = igor
+ pkgdesc = proofreader for mdoc(7) and docbook files
+ pkgver = 1.595
+ pkgrel = 1
+ url = http://www.wonkity.com/~wblock/igor
+ arch = any
+ license = BSD
+ options = !strip
+ source = http://docscripts.glenbarber.us/tags/igor/1.595/igor-1.595.tar.gz
+ source = igor.patch
+ sha256sums = f0e1895235d6dac23f94759dd013a8bcb9b8d0235bfe44fb65f3a19c804810a4
+ sha256sums = e2fc335879143faf9ed2d7ddb7757747dcfad9a1b8c04ce85239ab35aca54718
+
+pkgname = igor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..736dae6b5f36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: KingofToasters <themanhimself at sgregoratto dot me>
+
+pkgname=igor
+pkgver=1.595
+pkgrel=1
+pkgdesc="proofreader for mdoc(7) and docbook files"
+url="http://www.wonkity.com/~wblock/igor"
+_mirror="http://docscripts.glenbarber.us/tags/igor"
+arch=('any')
+license=('BSD')
+options=('!strip')
+source=("$_mirror/$pkgver/$pkgname-$pkgver.tar.gz"
+ 'igor.patch')
+sha256sums=('f0e1895235d6dac23f94759dd013a8bcb9b8d0235bfe44fb65f3a19c804810a4'
+ 'e2fc335879143faf9ed2d7ddb7757747dcfad9a1b8c04ce85239ab35aca54718')
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i "${srcdir}/igor.patch"
+}
+
+package() {
+ install -Dm755 "$pkgname-$pkgver/igor" "${pkgdir}/usr/bin/igor"
+ install -Dm644 "$pkgname-$pkgver/igor.1" "${pkgdir}/usr/share/man/man1/igor.1"
+}
diff --git a/igor.patch b/igor.patch
new file mode 100644
index 000000000000..72bb2923374e
--- /dev/null
+++ b/igor.patch
@@ -0,0 +1,49 @@
+Chunk 1: Change gzcat command
+Chunk 2-4: Do not use /usr/local/etc/
+ Originally authored by Ingo Schwarze <schwarze@openbsd.org>
+diff -ura igor-1.595.orig/igor igor-1.595.new/igor
+--- igor-1.595.orig/igor 2016-09-10 04:14:06.000000000 +1000
++++ igor-1.595.new/igor 2019-01-02 00:10:42.894811744 +1100
+@@ -40,7 +40,7 @@
+ use POSIX qw/strftime/;
+
+ my $file = "/usr/bin/file";
+-my $gzcat = "/usr/bin/gzcat";
++my $gzcat = "/usr/bin/zcat";
+ my $bzcat = "/usr/bin/bzcat";
+ my $man = "/usr/bin/man";
+
+@@ -1017,8 +1017,8 @@
+ my @spellfiles;
+ # IGORSPELLFILES environment variable is a whitespace-separated list of files
+ push (@spellfiles, split /\s/, $ENV{'IGORSPELLFILES'}) if defined($ENV{'IGORSPELLFILES'});
+- # all files found in /usr/local/etc/igor/spelling
+- push (@spellfiles, split /\s/, `ls /usr/local/etc/igor/spelling/*`) if -d '/usr/local/etc/igor/spelling';
++ # all files found in /etc/igor/spelling
++ push (@spellfiles, split /\s/, `ls /etc/igor/spelling/*`) if -d '/etc/igor/spelling';
+ for my $spellfile (@spellfiles) {
+ readspelling($spellfile);
+ }
+diff -ura igor-1.595.orig/igor.1 igor-1.595.new/igor.1
+--- igor-1.595.orig/igor.1 2016-09-10 04:14:06.000000000 +1000
++++ igor-1.595.new/igor.1 2019-01-02 00:10:51.108263129 +1100
+@@ -154,7 +154,7 @@
+ Additional files of misspelled words may be added with the
+ .Ev IGORSPELLFILES
+ environment variable, or placed in the
+-.Pa /usr/local/etc/igor/spelling
++.Pa /etc/igor/spelling
+ directory.
+ The first word on each line, including apostrophes, will be included in the
+ list of known misspellings to be checked.
+@@ -271,8 +271,8 @@
+ words.
+ .El
+ .Sh FILES
+-.Bl -tag -width /usr/local/etc/igor/spelling/
+-.It Pa /usr/local/etc/igor/spelling/
++.Bl -tag -width /etc/igor/spelling/
++.It Pa /etc/igor/spelling/
+ Directory for additional misspelled word files.
+ .El
+ .Sh EXAMPLES