summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2015-07-09 22:09:33 +0300
committerMantas Mikulėnas2015-07-09 22:12:17 +0300
commit72a94d797b1ce25a9c6dbfa20e50a1ee3d7e506c (patch)
tree90cada3253ace4f59f02e37a2e8c63b8d8853187
downloadaur-72a94d797b1ce25a9c6dbfa20e50a1ee3d7e506c.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e89faa3bf2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = igtf-trust-anchors
+ pkgdesc = EUGridPMA IGTF Trust Anchor distribution
+ pkgver = 1.65
+ pkgrel = 1
+ url = https://dist.igtf.net/
+ arch = any
+ source = https://dist.eugridpma.info/distribution/current/igtf-policy-installation-bundle-1.65.tar.gz
+ source = https://dist.eugridpma.info/distribution/current/igtf-policy-installation-bundle-1.65.tar.gz.asc
+ sha1sums = f586b0d8078abd84a9f2731e621e15c830b07606
+ sha1sums = SKIP
+
+pkgname = igtf-trust-anchors
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de714cf31b20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mantas Mikulėnas <grawity@gmail.com>
+
+pkgname=igtf-trust-anchors
+_pkgname=igtf-policy-installation-bundle
+pkgver=1.65
+pkgrel=1
+pkgdesc="EUGridPMA IGTF Trust Anchor distribution"
+arch=(any)
+url="https://dist.igtf.net/"
+source=(https://dist.eugridpma.info/distribution/current/$_pkgname-$pkgver.tar.gz{,.asc})
+sha1sums=('f586b0d8078abd84a9f2731e621e15c830b07606'
+ 'SKIP')
+validpgpkeys=('D12E922822BE64D50146188BC32D99C83CDBBC71')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ ./configure --prefix="$pkgdir/etc/grid-security/certificates" \
+ --with-install="install -m 644" \
+ --with-profile="all-accredited" ;
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make install
+}
+
+# vim: ft=sh:ts=2:sw=2:et