summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Alexandrowicz2017-01-11 00:41:29 -0500
committerTom Alexandrowicz2017-01-11 00:41:29 -0500
commit33ce28ceca79c9d793ad4fc46b8ff18f89df2cf6 (patch)
treeea3d295daa26b9909a3944c6a09686df571cc7ca
parent3e2cced372494c93449f89e3460160b1c1c58bb0 (diff)
downloadaur-iguanair-lirc.tar.gz
remove the including of the headers from iguanair, but still keep the linking of the object files, the driver seems to need it... add a dependency on the iguanair daemon which is needed to actually use the driver
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 85974b3b883e..9f9c5bd08182 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
# Maintainer: Tom Alexandrowicz <tom@alexandrowicz.ca>
pkgname='iguanair-lirc'
pkgver=e0cb127_e23b9d3
-pkgrel=1
+pkgrel=2
pkgdesc="LIRC driver for IguanaIR devices"
arch=('i686' 'x86_64')
url="https://github.com/iguanaworks/iguanair-lirc"
license=('GPL2')
-depends=('lirc')
+depends=('lirc' 'iguanair')
makedepends=('git' 'cmake')
source=("iguanair::git+https://github.com/iguanaworks/iguanair"
"$pkgname::git+https://github.com/iguanaworks/iguanair-lirc.git")
@@ -23,7 +23,7 @@ build() {
cd $srcdir/$pkgname
patch -p0 < $startdir/Makefile.patch
- make IGUANADIR="$srcdir/iguanair/software/usb_ir" CFLAGS+="-I $srcdir/iguanair/software/usb_ir" CFLAGS+='-D PLUGINDOCS="\"X\""' CFLAGS+='-fPIC'
+ make IGUANADIR="$srcdir/iguanair/software/usb_ir"
}
package() {
cd $pkgname