summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Alexandrowicz2017-01-10 23:41:32 -0500
committerTom Alexandrowicz2017-01-10 23:41:32 -0500
commit3e2cced372494c93449f89e3460160b1c1c58bb0 (patch)
treee9653032d363295ee4c3061d4caf1aeffde8d6a7
parentdc02544c540c1ebfa0538b066e77b279473f2b5f (diff)
downloadaur-3e2cced372494c93449f89e3460160b1c1c58bb0.tar.gz
Include the header file from iguanair when building iguanair-lirc. Also some strange thing about -fPIC because I don't think I know how to add include paths properly
-rw-r--r--Makefile.patch4
-rw-r--r--PKGBUILD2
2 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.patch b/Makefile.patch
index a9f7e183fd31..8855010022e7 100644
--- a/Makefile.patch
+++ b/Makefile.patch
@@ -1,7 +1,7 @@
diff --git Makefile Makefile
old mode 100755
new mode 100644
-index c6a7f7a..71c4a69
+index c6a7f7a..8e853c7
--- Makefile
+++ Makefile
@@ -18,19 +18,18 @@ PLUGINDIR ?= $(shell pkg-config --variable=plugindir lirc-driver)
@@ -15,7 +15,7 @@ index c6a7f7a..71c4a69
$(driver).so: $(driver).o
- gcc --shared -fpic $(LDFLAGS) -o $@ $<
-+ gcc --shared -fpic $(LDFLAGS) -o $@ $< $(IGUANADIR)/*.o
++ gcc --shared -fpic $(LDFLAGS) -o $@ $< $(IGUANADIR)/CMakeFiles/iguanaIR.dir/*.o
install: $(driver).so
- install $< $(PLUGINDIR)
diff --git a/PKGBUILD b/PKGBUILD
index c88bd7efe46c..85974b3b883e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ build() {
cd $srcdir/$pkgname
patch -p0 < $startdir/Makefile.patch
- make IGUANADIR="$srcdir/iguanair/software/usb_ir/CMakeFiles/iguanaIR.dir/"
+ make IGUANADIR="$srcdir/iguanair/software/usb_ir" CFLAGS+="-I $srcdir/iguanair/software/usb_ir" CFLAGS+='-D PLUGINDOCS="\"X\""' CFLAGS+='-fPIC'
}
package() {
cd $pkgname