summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiehong Ma2015-08-22 11:12:07 +0200
committerJiehong Ma2015-08-22 11:12:07 +0200
commit201ef94d57faa74c203c5990f8f5e0042ce24242 (patch)
tree57a6ec5a214e4aab063034fe9d9b2aeeba57d4a3
downloadaur-201ef94d57faa74c203c5990f8f5e0042ce24242.tar.gz
Initial import, but have to wait for Ipython 4 support
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD36
-rw-r--r--stack.patch10
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52126bfc8d02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ihaskell-git
+ pkgdesc = A Haskell kernel for IPython, built in a sandbox.
+ pkgver = c7196b1029
+ pkgrel = 1
+ url = https://github.com/gibiansky/IHaskell
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = ghc<7.11
+ makedepends = happy
+ makedepends = gtk2hs-buildtools
+ makedepends = haskell-stack
+ depends = ipython>=4
+ depends = python-pyzmq
+ depends = jupyter
+ provides = ihaskell
+ source = git+https://github.com/gibiansky/IHaskell
+ source = stack.patch
+ sha512sums = SKIP
+ sha512sums = 04f6797a49deda3300fb058501a5cc500549f1e436d91e4cd8416ff4bbbf4f1033984cd9ca5304fddbd5aca7a3bf4bc66473fbad5f7f55187359ecd0d9353f8c
+
+pkgname = ihaskell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a31f69f1f67e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jiehong Ma <email@majiehong.com>
+
+pkgname=ihaskell-git
+pkgver=c7196b1029
+pkgrel=1
+pkgdesc="A Haskell kernel for IPython, built in a sandbox."
+arch=('i686' 'x86_64')
+url="https://github.com/gibiansky/IHaskell"
+license=('MIT')
+depends=('ipython>=4' 'python-pyzmq' 'jupyter')
+makedepends=('git' 'ghc<7.11' 'happy' 'gtk2hs-buildtools' 'haskell-stack')
+provides=('ihaskell')
+conflicts=()
+source=("git+https://github.com/gibiansky/IHaskell" 'stack.patch')
+sha512sums=('SKIP'
+ '04f6797a49deda3300fb058501a5cc500549f1e436d91e4cd8416ff4bbbf4f1033984cd9ca5304fddbd5aca7a3bf4bc66473fbad5f7f55187359ecd0d9353f8c')
+
+prepare()
+{
+ cd "$srcdir/IHaskell"
+ patch stack.yaml ../../stack.patch
+}
+
+build() {
+ cd "$srcdir/IHaskell"
+ stack install ghc-parser --no-copy-bins
+ stack install ipython-kernel --no-copy-bins
+ stack install system-argv0 --no-copy-bins
+ stack install ihaskell --no-copy-bins
+}
+
+package() {
+ cd "$srcdir/IHaskell/.stack-work/install/x86_64-linux/nightly-2015-08-03/7.10.1/bin"
+ mkdir -p "$pkgdir/usr/bin/"
+ cp ihaskell "$pkgdir/usr/bin/ihaskell"
+}
diff --git a/stack.patch b/stack.patch
new file mode 100644
index 000000000000..219119f6f79c
--- /dev/null
+++ b/stack.patch
@@ -0,0 +1,10 @@
+diff --git a/stack.yaml b/stack.yaml
+index 35f4b98..06742e0 100644
+--- a/stack.yaml
++++ b/stack.yaml
+@@ -37,4 +37,4 @@ extra-deps:
+ - system-argv0-0.1.1
+ - vinyl-0.5.1
+ - xformat-0.1.2.1
+-resolver: nightly-2015-08-15
++resolver: nightly-2015-08-03