summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiehong Ma2016-08-19 22:24:47 +0200
committerAwesomeHaircut2017-12-05 19:22:21 -0700
commit6420f825528da3e99840806f6d6cf6357c08dcb4 (patch)
treef1080a817079ab2c775f0f20e6062989bac58d1d
parent070875b5b273ca4c06a7d4618bffd00d252cddee (diff)
downloadaur-6420f825528da3e99840806f6d6cf6357c08dcb4.tar.gz
bump: try to make version 8.4.0 available
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rw-r--r--patch14
3 files changed, 24 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2afbe5bfe951..abf22f9064be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 9 21:47:19 UTC 2016
+# Fri Aug 19 20:24:20 UTC 2016
pkgbase = ihaskell-git
- pkgdesc = A Haskell kernel for IPython, built in a sandbox.
- pkgver = 0.8.3
+ pkgdesc = A Haskell kernel for Jupyter, built in a sandbox.
+ pkgver = 0.8.4
pkgrel = 1
url = https://github.com/gibiansky/IHaskell
arch = i686
@@ -10,17 +10,16 @@ pkgbase = ihaskell-git
license = MIT
makedepends = git
makedepends = happy
- makedepends = gtk2hs-buildtools
- makedepends = haskell-stack
- depends = ipython>=4
+ makedepends = haskell-gtk2hs-buildtools
depends = python-pyzmq
depends = jupyter
- depends = ghc=7.10.3
+ depends = haskell-stack
+ depends = ghc7.10-bin
provides = ihaskell
source = git+https://github.com/gibiansky/IHaskell
source = patch
sha512sums = SKIP
- sha512sums = 34b08fb46b428fc871660415a3bc16864f4136aaf15792334d378eb6ebd4e78cb358039723c70767f4fe2369e042c0d9e6ef6a7117e420a00f0da263c7131210
+ sha512sums = 6340595cafddcdcec315d086523d9c35539653fb8079ea56ddf75c15e3103fe81cccf3f98665d37dee9d3d46459985d10ff93ad5b66eb89a3ffb6265b5efec2f
pkgname = ihaskell-git
diff --git a/PKGBUILD b/PKGBUILD
index 605a290279fb..94cb84d2e28f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,42 @@
# Maintainer: Jiehong Ma <email@majiehong.com>
pkgname=ihaskell-git
-pkgver=0.8.3
+pkgver=0.8.4
pkgrel=1
-pkgdesc="A Haskell kernel for IPython, built in a sandbox."
+pkgdesc="A Haskell kernel for Jupyter, built in a sandbox."
arch=('i686' 'x86_64')
url="https://github.com/gibiansky/IHaskell"
license=('MIT')
-depends=('ipython>=4' 'python-pyzmq' 'jupyter' 'ghc=7.10.3')
-makedepends=('git' 'happy' 'gtk2hs-buildtools' 'haskell-stack')
+depends=('python-pyzmq' 'jupyter' 'haskell-stack' 'ghc7.10-bin')
+makedepends=('git' 'happy' 'haskell-gtk2hs-buildtools')
provides=('ihaskell')
conflicts=()
source=("git+https://github.com/gibiansky/IHaskell" "patch")
sha512sums=('SKIP'
- '34b08fb46b428fc871660415a3bc16864f4136aaf15792334d378eb6ebd4e78cb358039723c70767f4fe2369e042c0d9e6ef6a7117e420a00f0da263c7131210')
+ '6340595cafddcdcec315d086523d9c35539653fb8079ea56ddf75c15e3103fe81cccf3f98665d37dee9d3d46459985d10ff93ad5b66eb89a3ffb6265b5efec2f')
prepare()
{
cd "$srcdir/IHaskell"
+ git checkout 73791d3
patch "stack.yaml" "../../patch"
}
build() {
+ export STACK_ROOT="$HOME/.stack/"
cd "$srcdir/IHaskell"
- #git checkout "v${pkgver}.0"
- git checkout 1b6d908
stack setup
printf '%s\n' 'If you never used stack before, run `stack init` first.'
stack install ghc-parser --no-copy-bins
stack install ipython-kernel --no-copy-bins
stack install system-argv0 --no-copy-bins
stack install ihaskell --no-copy-bins
+ stack build
+ stack build
}
package() {
- cd "$srcdir/IHaskell/.stack-work/install/x86_64-linux/lts-5.6/7.10.3/bin"
- mkdir -p "$pkgdir/usr/bin/"
- cp ihaskell "$pkgdir/usr/bin/ihaskell"
printf '\n%s\n' 'Now, install ihaskell with `ihaskell install`, and enjoy it in `jupyter notebook`!'
- printf '%s\n\n' 'Also make sure to set resolver to `resolver: lts-5.6` in your ~/.stack/global/stack.yaml file.'
+ printf '%s\n\n' 'Also make sure to set resolver to `resolver: lts-6.2` in your ~/.stack/global/stack.yaml file.'
printf '%s\n' 'If you run in any issue, make sure to check that you initialiazed stack with `stack init`' 'But change the resolver as mentionned'
}
diff --git a/patch b/patch
index 58339fffb48f..5fa1d0c6aaa3 100644
--- a/patch
+++ b/patch
@@ -1,10 +1,10 @@
diff --git a/stack.yaml b/stack.yaml
-index 6d3f37c..6f9c6f6 100644
+index 3f33b46a1fe2..fac7d8b8dfd2 100644
--- a/stack.yaml
+++ b/stack.yaml
-@@ -24,4 +24,4 @@ extra-deps:
- - xformat-0.1.2.1
- - ratio-int-0.1.2
- - friday-0.2.2.0
--resolver: nightly-2015-08-15
-+resolver: lts-5.6
+@@ -6,3 +6,5 @@ packages:
+ resolver: lts-6.2
+ extra-deps:
+ - system-argv0-0.1.1 # Necessary for LTS 2.22 (GHC 7.8)
++ghc-options:
++ "*": -static -optl-pthread -optc-static -optl-static