summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiehong Ma2016-03-09 22:46:00 +0100
committerJiehong Ma2016-03-09 22:47:39 +0100
commit708a9c7c748c3098768ab8e87c3907bdbff132c2 (patch)
tree6495a534ee9f83e9756c0cb9290b48725a84e7f0
parent8613aabcd72b185be39907d882be3504c1f27638 (diff)
downloadaur-708a9c7c748c3098768ab8e87c3907bdbff132c2.tar.gz
Update to v0.8.3.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rw-r--r--patch10
3 files changed, 27 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40825766f311..2afbe5bfe951 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Mar 9 21:47:19 UTC 2016
pkgbase = ihaskell-git
pkgdesc = A Haskell kernel for IPython, built in a sandbox.
- pkgver = 0.8.2
+ pkgver = 0.8.3
pkgrel = 1
url = https://github.com/gibiansky/IHaskell
arch = i686
@@ -13,10 +15,12 @@ pkgbase = ihaskell-git
depends = ipython>=4
depends = python-pyzmq
depends = jupyter
- depends = ghc=7.10.2
+ depends = ghc=7.10.3
provides = ihaskell
source = git+https://github.com/gibiansky/IHaskell
+ source = patch
sha512sums = SKIP
+ sha512sums = 34b08fb46b428fc871660415a3bc16864f4136aaf15792334d378eb6ebd4e78cb358039723c70767f4fe2369e042c0d9e6ef6a7117e420a00f0da263c7131210
pkgname = ihaskell-git
diff --git a/PKGBUILD b/PKGBUILD
index 8174e0d35746..605a290279fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
# Maintainer: Jiehong Ma <email@majiehong.com>
pkgname=ihaskell-git
-pkgver=0.8.2
+pkgver=0.8.3
pkgrel=1
pkgdesc="A Haskell kernel for IPython, built in a sandbox."
arch=('i686' 'x86_64')
url="https://github.com/gibiansky/IHaskell"
license=('MIT')
-depends=('ipython>=4' 'python-pyzmq' 'jupyter' 'ghc=7.10.2')
+depends=('ipython>=4' 'python-pyzmq' 'jupyter' 'ghc=7.10.3')
makedepends=('git' 'happy' 'gtk2hs-buildtools' 'haskell-stack')
provides=('ihaskell')
conflicts=()
-source=("git+https://github.com/gibiansky/IHaskell")
-sha512sums=('SKIP')
+source=("git+https://github.com/gibiansky/IHaskell" "patch")
+sha512sums=('SKIP'
+ '34b08fb46b428fc871660415a3bc16864f4136aaf15792334d378eb6ebd4e78cb358039723c70767f4fe2369e042c0d9e6ef6a7117e420a00f0da263c7131210')
prepare()
{
cd "$srcdir/IHaskell"
+ patch "stack.yaml" "../../patch"
}
build() {
cd "$srcdir/IHaskell"
- # git checkout "v${pkgver}.0"
- git checkout 89ba1ded48d19cfb2ec3a4d347007e2e1d261969
+ #git checkout "v${pkgver}.0"
+ git checkout 1b6d908
stack setup
printf '%s\n' 'If you never used stack before, run `stack init` first.'
stack install ghc-parser --no-copy-bins
@@ -32,10 +34,10 @@ build() {
}
package() {
- cd "$srcdir/IHaskell/.stack-work/install/x86_64-linux/nightly-2015-08-15/7.10.2/bin"
+ cd "$srcdir/IHaskell/.stack-work/install/x86_64-linux/lts-5.6/7.10.3/bin"
mkdir -p "$pkgdir/usr/bin/"
cp ihaskell "$pkgdir/usr/bin/ihaskell"
- printf '\n%s\n' 'Now, install ihaskell with `ihaskell install`, and enjoy it in ipython notebook or console!'
- printf '%s\n\n' 'Also make sure to set resolver to `resolver: nightly-2015-08-15` in your ~/.stack/global/stack.yaml file.'
+ printf '\n%s\n' 'Now, install ihaskell with `ihaskell install`, and enjoy it in `jupyter notebook`!'
+ printf '%s\n\n' 'Also make sure to set resolver to `resolver: lts-5.6` in your ~/.stack/global/stack.yaml file.'
printf '%s\n' 'If you run in any issue, make sure to check that you initialiazed stack with `stack init`' 'But change the resolver as mentionned'
}
diff --git a/patch b/patch
new file mode 100644
index 000000000000..58339fffb48f
--- /dev/null
+++ b/patch
@@ -0,0 +1,10 @@
+diff --git a/stack.yaml b/stack.yaml
+index 6d3f37c..6f9c6f6 100644
+--- a/stack.yaml
++++ b/stack.yaml
+@@ -24,4 +24,4 @@ extra-deps:
+ - xformat-0.1.2.1
+ - ratio-int-0.1.2
+ - friday-0.2.2.0
+-resolver: nightly-2015-08-15
++resolver: lts-5.6