summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiehong Ma2015-09-02 23:12:11 +0200
committerJiehong Ma2015-09-02 23:12:11 +0200
commit8c377eb8d021d2d667c43eee5e1573ddcd196f45 (patch)
tree2b9e140ab0afbf68e77ce37db68a549ea0c4730e
parentea970b4d3b2fe8e076a5d52e9d74ec4c62045a27 (diff)
downloadaur-8c377eb8d021d2d667c43eee5e1573ddcd196f45.tar.gz
Add a warning if people didn't install Stack before
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83c232ab04b4..d9bf995f595b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ihaskell-git
pkgdesc = A Haskell kernel for IPython, built in a sandbox.
pkgver = 0.7.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/gibiansky/IHaskell
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 384ddc9d8e4c..8cfe7700d761 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
pkgname=ihaskell-git
pkgver=0.7.0
-pkgrel=3
+pkgrel=4
pkgdesc="A Haskell kernel for IPython, built in a sandbox."
arch=('i686' 'x86_64')
url="https://github.com/gibiansky/IHaskell"
license=('MIT')
depends=('ipython>=4' 'python-pyzmq' 'jupyter' 'ghc<7.11')
-makedepends=('git' '
- happy' 'gtk2hs-buildtools' 'haskell-stack')
+makedepends=('git' 'happy' 'gtk2hs-buildtools' 'haskell-stack')
provides=('ihaskell')
conflicts=()
source=("git+https://github.com/gibiansky/IHaskell" 'stack.yaml.patch')
@@ -24,6 +23,7 @@ prepare()
build() {
cd "$srcdir/IHaskell"
+ stack init
stack install ghc-parser --no-copy-bins
stack install ipython-kernel --no-copy-bins
stack install system-argv0 --no-copy-bins
@@ -34,6 +34,7 @@ package() {
cd "$srcdir/IHaskell/.stack-work/install/x86_64-linux/nightly-2015-08-03/7.10.1/bin"
mkdir -p "$pkgdir/usr/bin/"
cp ihaskell "$pkgdir/usr/bin/ihaskell"
- printf '\n%s\n' "Now, install ihaskell with `ihaskell install`, and enjoy it in ipython notebook or console!"
- printf '%s\n' 'Also make sure to set resolver to `resolver: nightly-2015-08-03` in your ~/.stack/global/stack.yaml file.'
+ printf '\n%s\n' 'Now, install ihaskell with `ihaskell install`, and enjoy it in ipython notebook or console!'
+ printf '%s\n\n' 'Also make sure to set resolver to `resolver: nightly-2015-08-03` in your ~/.stack/global/stack.yaml file.'
+ printf '%s\n' 'If you run in any issue, make sure to check that you initialiazed stack with `stack init`' 'But change the resolver as mentionned'
}