summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAwesomeHaircut2017-12-05 19:35:01 -0700
committerAwesomeHaircut2017-12-05 19:35:01 -0700
commitf92dca3b1a00de1c3dfb6c354b9734580a86b2a0 (patch)
tree10e763e50473f5c070fd4077817ea757932e1ff8
parent1d67b836e1dae75eacbbfcb87a6e57fb525a5681 (diff)
downloadaur-f92dca3b1a00de1c3dfb6c354b9734580a86b2a0.tar.gz
modified: .SRCINFO
modified: PKGBUILD deleted: patch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--patch10
3 files changed, 5 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abf22f9064be..455e8fe6a684 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Fri Aug 19 20:24:20 UTC 2016
pkgbase = ihaskell-git
pkgdesc = A Haskell kernel for Jupyter, built in a sandbox.
pkgver = 0.8.4
@@ -13,13 +11,11 @@ pkgbase = ihaskell-git
makedepends = haskell-gtk2hs-buildtools
depends = python-pyzmq
depends = jupyter
- depends = haskell-stack
- depends = ghc7.10-bin
+ depends = stack
+ depends = ghc
provides = ihaskell
source = git+https://github.com/gibiansky/IHaskell
- source = patch
sha512sums = SKIP
- sha512sums = 6340595cafddcdcec315d086523d9c35539653fb8079ea56ddf75c15e3103fe81cccf3f98665d37dee9d3d46459985d10ff93ad5b66eb89a3ffb6265b5efec2f
pkgname = ihaskell-git
diff --git a/PKGBUILD b/PKGBUILD
index 94cb84d2e28f..a438cf3cdd30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,19 +7,16 @@ pkgdesc="A Haskell kernel for Jupyter, built in a sandbox."
arch=('i686' 'x86_64')
url="https://github.com/gibiansky/IHaskell"
license=('MIT')
-depends=('python-pyzmq' 'jupyter' 'haskell-stack' 'ghc7.10-bin')
+depends=('python-pyzmq' 'jupyter' 'stack' 'ghc')
makedepends=('git' 'happy' 'haskell-gtk2hs-buildtools')
provides=('ihaskell')
conflicts=()
-source=("git+https://github.com/gibiansky/IHaskell" "patch")
-sha512sums=('SKIP'
- '6340595cafddcdcec315d086523d9c35539653fb8079ea56ddf75c15e3103fe81cccf3f98665d37dee9d3d46459985d10ff93ad5b66eb89a3ffb6265b5efec2f')
+source=("git+https://github.com/gibiansky/IHaskell")
+sha512sums=('SKIP')
prepare()
{
cd "$srcdir/IHaskell"
- git checkout 73791d3
- patch "stack.yaml" "../../patch"
}
build() {
diff --git a/patch b/patch
deleted file mode 100644
index 5fa1d0c6aaa3..000000000000
--- a/patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/stack.yaml b/stack.yaml
-index 3f33b46a1fe2..fac7d8b8dfd2 100644
---- a/stack.yaml
-+++ b/stack.yaml
-@@ -6,3 +6,5 @@ packages:
- resolver: lts-6.2
- extra-deps:
- - system-argv0-0.1.1 # Necessary for LTS 2.22 (GHC 7.8)
-+ghc-options:
-+ "*": -static -optl-pthread -optc-static -optl-static