summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112018-12-11 22:47:02 +0100
committerjose17112018-12-11 22:47:02 +0100
commit132bf9d8bac13668e3a984025fc0c76e57a06fcd (patch)
tree53eab650c2d21e724a740d32a3ccc7563ca50280
downloadaur-132bf9d8bac13668e3a984025fc0c76e57a06fcd.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb653167c331
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Dec 11 21:46:50 UTC 2018
+pkgbase = ihu-git
+ pkgdesc = I Hear U VoIP application that creates an audio stream between two computers
+ pkgver = r7.3587923
+ pkgrel = 1
+ url = https://github.com/jose1711/ihu
+ arch = i686
+ arch = x86_64
+ license = GPL-2
+ depends = qt4
+ depends = speex
+ depends = soundtouch
+ depends = jack2
+ provides = ihu
+ conflicts = ihu
+ source = git://github.com/jose1711/ihu.git
+ sha256sums = SKIP
+
+pkgname = ihu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4d993747c11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jose Riha <jose1711 at gmail dot com>
+
+pkgname=ihu-git
+_pkgname=ihu
+pkgver=r7.3587923
+pkgrel=1
+pkgdesc='I Hear U VoIP application that creates an audio stream between two computers'
+arch=('i686' 'x86_64')
+url="https://github.com/jose1711/ihu"
+license=('GPL-2')
+depends=('qt4' 'speex' 'soundtouch' 'jack2')
+provides=('ihu')
+conflicts=('ihu')
+source=("git://github.com/jose1711/ihu.git")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="$pkgdir/" install
+}