summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKasper Eenberg2015-11-16 12:34:18 +0100
committerKasper Eenberg2015-11-16 12:34:18 +0100
commit8fed6e5df9540848ef75d95ce3e998cacb3e5958 (patch)
tree58c374f8899e681a4f3100a817af843e1a76d064
downloadaur-8fed6e5df9540848ef75d95ce3e998cacb3e5958.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48b4a7dd93da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ijvm-tools
+ pkgdesc = Implementation of the IJVM machine described in the book Structured Computer Organization
+ pkgver = 0.9
+ pkgrel = 1.0
+ url = https://users-cs.au.dk/bouvin/dComArk/2015/noter/Note_2/
+ arch = x86_64
+ license = GPL2
+ provides = ijvm
+ source = ijvm-tools-0.9.tar.gz::https://users-cs.au.dk/bouvin/dComArk/2015/noter/Note_2/ijvm-tools-0.9.tar.gz
+ sha512sums = 29fb6076b30a63cf3db64f96972928e1a4c281defcc71fa124a795be1dc3f10322cd11e0bc880adfa50d0be423e8f45826c7515bdd90f52e5258053e700ed1bc
+
+pkgname = ijvm-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be7b12bc9c77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Kasper Sacharias Roos Eenberg <kse@mahavira.dk>
+pkgname=ijvm-tools
+pkgver=0.9
+pkgrel=1.0
+pkgdesc="Implementation of the IJVM machine described in the book Structured Computer Organization"
+provides=('ijvm')
+arch=('x86_64')
+url="https://users-cs.au.dk/bouvin/dComArk/2015/noter/Note_2/"
+license=('GPL2')
+source=("ijvm-tools-${pkgver}.tar.gz::https://users-cs.au.dk/bouvin/dComArk/2015/noter/Note_2/ijvm-tools-${pkgver}.tar.gz")
+sha512sums=('29fb6076b30a63cf3db64f96972928e1a4c281defcc71fa124a795be1dc3f10322cd11e0bc880adfa50d0be423e8f45826c7515bdd90f52e5258053e700ed1bc')
+
+build() {
+ cd ijvm-tools-${pkgver}
+ ./configure --prefix ${pkgdir}/usr
+ make
+}
+
+package() {
+ cd ijvm-tools-${pkgver}
+ make install
+}