summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrockybulwinkle2022-04-04 14:53:28 -0500
committerrockybulwinkle2022-04-04 14:53:28 -0500
commit20d67b1e8643a25ba7040a5a62fb909071d9cdeb (patch)
treecf598a61a269bcc5f23e698b4fa6ab30fa4591de
parent6e7d3343ec523eb43789a1b03aec65cfff10756c (diff)
downloadaur-20d67b1e8643a25ba7040a5a62fb909071d9cdeb.tar.gz
Fix for cmake threadlib
-rw-r--r--PKGBUILD7
-rw-r--r--cmake-threadlib.patch28
2 files changed, 33 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e30a7eb73850..67236e916076 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,14 +14,17 @@ depends=(openssl libedit)
makedepends=(cmake)
optdepends=(openldap)
backup=(etc/iked.conf)
-source=("http://www.shrew.net/download/ike/ike-$pkgver-release.tgz" iked.service openssl-1.1.0.patch)
+source=("http://www.shrew.net/download/ike/ike-$pkgver-release.tgz" iked.service openssl-1.1.0.patch cmake-threadlib.patch)
md5sums=('3dac18a2da5809ccb38c50cd4a455897'
'3cb3ff3b663805f76be1efd527ae436c'
- '57348fe9112555c0204709c1716e5fff')
+ '57348fe9112555c0204709c1716e5fff'
+ '4c823bae9e006cf7bfb11fa633a59837'
+ )
prepare () {
cd "$srcdir/ike"
patch -p1 -i "$srcdir/openssl-1.1.0.patch"
+ patch -p1 -i "$srcdir/cmake-threadlib.patch"
sed -i 's/define "parser_class_name"/define parser_class_name/' ./source/iked/conf.parse.yy
}
diff --git a/cmake-threadlib.patch b/cmake-threadlib.patch
new file mode 100644
index 000000000000..323e049ff90b
--- /dev/null
+++ b/cmake-threadlib.patch
@@ -0,0 +1,28 @@
+diff --unified --recursive --text --color package.orig/ike/CMakeLists.txt package.new/ike/CMakeLists.txt
+--- a/CMakeLists.txt 2022-04-04 14:41:54.512667837 -0500
++++ b/CMakeLists.txt 2022-04-04 14:42:13.302667617 -0500
+@@ -321,15 +321,15 @@
+
+ endif( NOT CMAKE_USE_PTHREADS_INIT )
+
+-if( NOT APPLE )
+-
+- check_library_exists(
+- ${CMAKE_THREAD_LIBS_INIT}
+- "pthread_mutex_timedlock"
+- ""
+- FUNC_LIB_TIMEDLOCK )
+-
+-endif( NOT APPLE )
++#if( NOT APPLE )
++#
++# check_library_exists(
++# ${CMAKE_THREAD_LIBS_INIT}
++# "pthread_mutex_timedlock"
++# ""
++# FUNC_LIB_TIMEDLOCK )
++#
++#endif( NOT APPLE )
+
+ if( FUNC_LIB_TIMEDLOCK )
+