summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Arthaud2018-10-17 08:47:07 -0700
committerMaxime Arthaud2018-10-17 08:47:07 -0700
commit38d18327d3d02f3d3af1b0f7f3e492e91cbc71f4 (patch)
treeab2eeb4364a86ea3bc0c191710aabef83c391184
parentdb34bc0febb35dd55b1beb4b1f772292bb9afc66 (diff)
downloadaur-38d18327d3d02f3d3af1b0f7f3e492e91cbc71f4.tar.gz
Update ikos 2.0
-rw-r--r--.SRCINFO20
-rw-r--r--CMakeLists.patch10
-rw-r--r--PKGBUILD51
3 files changed, 35 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fb6a16f0dcf..19e9002cb0f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,29 @@
-# Generated by mksrcinfo v8
-# Wed Oct 25 06:40:11 UTC 2017
pkgbase = ikos
- pkgdesc = A static analysis tool for C/C++ developed by NASA
- pkgver = 1.3
+ pkgdesc = A static analyzer for C and C++ developed by NASA
+ pkgver = 2.0
pkgrel = 1
url = https://ti.arc.nasa.gov/opensource/ikos/
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
license = custom:NOSA 1.3
makedepends = cmake
makedepends = boost
depends = gmp
depends = boost-libs
depends = python
+ depends = python-pygments
depends = sqlite
depends = llvm40
depends = llvm40-libs
depends = clang40
- source = https://ti.arc.nasa.gov/m/opensource/downloads/ikos-1.3.tar.gz
+ depends = apron-ppl-svn
+ source = https://ti.arc.nasa.gov/m/opensource/downloads/ikos-2.0.tar.gz
source = https://ti.arc.nasa.gov/m/opensource/downloads/ikos/IKOS_NASA_Open_Source_Agreement.pdf
- source = CMakeLists.patch
- sha512sums = cec1b914bd1a7ca449098a2393baae35f066498ef99982f7b876aaa1590ea0e752441336093184285dccce392a326824a7a1e47cc04e9406df826870874fa147
+ sha512sums = f3abb77e9d3d57b26cb0df7d26b1cb824441c178205edc7b92b3b137d6b2b12b9f7336d53f5135a8a0f114042c193419945553fac0f91b59235e8ed5849fb3d5
sha512sums = 3caeffbe06254b3a181eee1f172bde48d7c8007e989b07928b0ce4e737759d5e2649d25419722c3b7a78ca8ddf408ce150a143490489641527cbcac479c241b7
- sha512sums = 59b0fc0cd11979b2d341c776efcbc4acb8ef514610dbd04d2436a8a56f8daa6f7eb3041691770ca62037911f255bb6926fafa9d81d574ed2f13111a4d39a474c
pkgname = ikos
diff --git a/CMakeLists.patch b/CMakeLists.patch
deleted file mode 100644
index 861ee5d2d958..000000000000
--- a/CMakeLists.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- analyzer/CMakeLists.txt 2017-10-24 23:27:47.506846743 -0700
-+++ analyzer/CMakeLists.txt 2017-10-24 23:28:18.176845066 -0700
-@@ -254,6 +254,7 @@
-
- install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} setup.py install
- \"--prefix=${CMAKE_INSTALL_PREFIX}\"
-+ \"--root=\$DESTDIR\"
- WORKING_DIRECTORY \"${CMAKE_CURRENT_BINARY_DIR}/python\")")
-
- # python scripts
diff --git a/PKGBUILD b/PKGBUILD
index 7035030eb462..ed2eac539d95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,50 @@
# Maintainer: Maxime Arthaud <maxime@arthaud.me>
pkgname=ikos
-pkgver=1.3
+pkgver=2.0
pkgrel=1
-_prefix="/usr/lib/ikos-$pkgver"
-pkgdesc='A static analysis tool for C/C++ developed by NASA'
-arch=('any')
+pkgdesc='A static analyzer for C and C++ developed by NASA'
+arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url='https://ti.arc.nasa.gov/opensource/ikos/'
license=('custom:NOSA 1.3')
-depends=('gmp' 'boost-libs' 'python' 'sqlite' 'llvm40' 'llvm40-libs' 'clang40')
-makedepends=('cmake' 'boost')
+depends=('gmp'
+ 'boost-libs'
+ 'python'
+ 'python-pygments'
+ 'sqlite'
+ 'llvm40'
+ 'llvm40-libs'
+ 'clang40'
+ 'apron-ppl-svn')
+makedepends=('cmake'
+ 'boost')
source=("https://ti.arc.nasa.gov/m/opensource/downloads/ikos-$pkgver.tar.gz"
- "https://ti.arc.nasa.gov/m/opensource/downloads/ikos/IKOS_NASA_Open_Source_Agreement.pdf"
- "CMakeLists.patch")
-sha512sums=('cec1b914bd1a7ca449098a2393baae35f066498ef99982f7b876aaa1590ea0e752441336093184285dccce392a326824a7a1e47cc04e9406df826870874fa147'
- '3caeffbe06254b3a181eee1f172bde48d7c8007e989b07928b0ce4e737759d5e2649d25419722c3b7a78ca8ddf408ce150a143490489641527cbcac479c241b7'
- '59b0fc0cd11979b2d341c776efcbc4acb8ef514610dbd04d2436a8a56f8daa6f7eb3041691770ca62037911f255bb6926fafa9d81d574ed2f13111a4d39a474c')
+ "https://ti.arc.nasa.gov/m/opensource/downloads/ikos/IKOS_NASA_Open_Source_Agreement.pdf")
+sha512sums=('f3abb77e9d3d57b26cb0df7d26b1cb824441c178205edc7b92b3b137d6b2b12b9f7336d53f5135a8a0f114042c193419945553fac0f91b59235e8ed5849fb3d5'
+ '3caeffbe06254b3a181eee1f172bde48d7c8007e989b07928b0ce4e737759d5e2649d25419722c3b7a78ca8ddf408ce150a143490489641527cbcac479c241b7')
prepare() {
cd "$srcdir/ikos-$pkgver"
-
mkdir build
-
- patch -Np0 < ../CMakeLists.patch
}
build() {
cd "$srcdir/ikos-$pkgver/build"
-
cmake \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="${_prefix}" \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
-DLLVM_CONFIG_EXECUTABLE="/usr/bin/llvm-config-4.0" \
..
-
make
}
package() {
cd "$srcdir/ikos-$pkgver/build"
-
make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/IKOS_NASA_Open_Source_Agreement.pdf" "${pkgdir}/usr/share/licenses/ikos/LICENSE"
+}
- install -Dm644 "$srcdir/IKOS_NASA_Open_Source_Agreement.pdf" "${pkgdir}${_prefix}/share/licenses/ikos/LICENSE"
-
- # add symbolic links in /usr/bin
- mkdir -p "$pkgdir/usr/bin"
- cd "${pkgdir}${_prefix}"/bin
- for f in *; do
- ln -s "${_prefix}/bin/$f" "$pkgdir/usr/bin/$f"
- done
+check() {
+ cd "$srcdir/ikos-$pkgver/build"
+ make check
}