summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-07-10 20:58:34 +0300
committerMr.Smith19742023-07-10 20:58:34 +0300
commite09771fe0ac9c9cccb42bcfc085180b1c411cea7 (patch)
treeb92b5a087018531146e3196dc124bd89a91ecaa6
parentd8b26b5c0df86d92976997d100be2f046da3008f (diff)
downloadaur-e09771fe0ac9c9cccb42bcfc085180b1c411cea7.tar.gz
Updated build
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ead281eb7505..c0779e2916b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ikos-git
pkgdesc = Static analyzer for C and C++ developed by NASA
- pkgver = 3.0.r409.72c70c7
+ pkgver = 3.1.r436.2e64743
pkgrel = 1
url = https://github.com/nasa-sw-vnv/ikos
arch = i686
@@ -17,13 +17,12 @@ pkgbase = ikos-git
depends = python-pygments
depends = sqlite
depends = intel-tbb
- depends = llvm
- depends = llvm-libs
- depends = clang
+ depends = llvm14
+ depends = llvm14-libs
+ depends = clang14
depends = apron
provides = ikos
- source = ikos-git::git://github.com/nasa-sw-vnv/ikos.git
+ source = ikos-git::git+http://github.com/nasa-sw-vnv/ikos.git
sha256sums = SKIP
pkgname = ikos-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4bf97db9dcc4..89e4d857d5a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Arthaud <maxime@arthaud.me>
pkgname=ikos-git
-pkgver=3.0.r409.72c70c7
+pkgver=3.1.r436.2e64743
pkgrel=1
pkgdesc='Static analyzer for C and C++ developed by NASA'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
@@ -14,13 +14,13 @@ depends=('gmp'
'python-pygments'
'sqlite'
'intel-tbb'
- 'llvm'
- 'llvm-libs'
- 'clang'
+ 'llvm14'
+ 'llvm14-libs'
+ 'clang14'
'apron')
makedepends=('cmake'
'boost')
-source=("$pkgname::git://github.com/nasa-sw-vnv/ikos.git")
+source=("$pkgname::git+http://github.com/nasa-sw-vnv/ikos.git")
sha256sums=('SKIP')
pkgver() {
@@ -33,7 +33,8 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
- mkdir build
+ [[ -d build ]] && rm -rf build
+ mkdir build && cd build
}
build() {
@@ -41,7 +42,7 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_PREFIX="/usr" \
- -DLLVM_CONFIG_EXECUTABLE="/usr/bin/llvm-config" \
+ -DLLVM_CONFIG_EXECUTABLE="/usr/bin/llvm-config-14" \
-DAPPEND_GIT_VERSION=ON \
..
make