summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Joram2023-02-04 12:57:20 +0200
committerCody P Schafer2023-02-05 11:03:59 -0500
commit0afc9f8ff78baa48d88916ff38a4bc7f41ff64d8 (patch)
tree77edea6f3661e229f444ebaed1bc7fae79234006
parent9993f813de5b11a7e7984e85bb60d02505d09bb0 (diff)
downloadaur-illum-git.tar.gz
fix: Enable cloning submodules from file:// URLs
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eae117b74f92..211693d0d483 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,10 @@ prepare () {
cd "$srcdir/$_bpn"
git submodule init
git config submodule.ccan.url $srcdir/ccan
- git submodule update
+
+ # Enable cloning from 'file://' URLs.
+ # Workaround for https://bugs.archlinux.org/task/76255
+ git -c protocol.file.allow=always submodule update
}
build () {