summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortplasdio2022-05-23 01:15:28 +0000
committertplasdio2022-05-23 01:15:28 +0000
commit7a9c19f2c1760b7232361e6a9eb8003ce028628a (patch)
tree3283fe0ff256ef7e6d48f71c19b21c163dad7411
downloadaur-7a9c19f2c1760b7232361e6a9eb8003ce028628a.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD54
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b14930adb98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ilua-git
+ pkgdesc = Portable Lua kernel for Jupyter
+ pkgver = 0.2.1.r135.05eb181
+ pkgrel = 1
+ url = https://github.com/guysv/ilua
+ arch = any
+ license = GPL2
+ makedepends = python-setuptools
+ depends = python
+ depends = lua
+ depends = python-jupyter_core
+ depends = jupyter_console
+ depends = python-txzmq
+ depends = python-twisted
+ depends = python-termcolor
+ depends = python-pygments
+ depends = python-service-identity
+ provides = ilua
+ source = git+https://github.com/guysv/ilua
+ sha256sums = SKIP
+
+pkgname = ilua-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b996c40ab6a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: articpenguin <julia.schweinz at mailfence dot com>
+
+pkgname=ilua-git
+_pkgname=ilua
+pkgver=0.2.1.r135.05eb181
+pkgrel=1
+pkgdesc="Portable Lua kernel for Jupyter "
+arch=(any)
+url="https://github.com/guysv/ilua"
+license=(GPL2)
+depends=(
+ python
+ lua
+ python-jupyter_core
+ jupyter_console
+ python-txzmq
+ python-twisted
+ python-termcolor
+ python-pygments
+ python-service-identity
+)
+makedepends=(python-setuptools)
+provides=('ilua')
+#conflicts=('') # It installs the kernel in /usr/share/jupyter/kernels/lua, not sure if it would conflict with other Lua Jupyter kernels packaged in the future
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ # TODO: get the pip version number which is somehow higher than the latest git tag
+ printf "%s.r%s.%s" \
+ "$(git describe --abbrev=0 --tags)" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+
+ python3 setup.py build
+}
+
+check() {
+ cd "$_pkgname"
+
+ python3 -m unittest
+}
+
+package() {
+ cd "$_pkgname"
+
+ python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}