summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2014-11-17 14:09:16 +0100
committerJohannes Dewender2014-11-17 14:09:16 +0100
commita7fab7cb5e2a7ad26cb119693efc0c9254352297 (patch)
tree3dc0152b46dcfaee975c7ddb9d4df4e044895875
parent09492068ac87c1d72c22a1691678390e02274ed1 (diff)
downloadaur-a7fab7cb5e2a7ad26cb119693efc0c9254352297.tar.gz
image-id: 2.1.0
Now using autotools to build, working with multiple libmirage versions.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c73aef8e9155..f5080493d45a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = image-id
pkgdesc = A tool to compute the MusicBrainz disc ID from a CD image
- pkgver = 2.0.0
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/kepstin/image-id
arch = x86_64
arch = i686
license = GPL2
depends = libdiscid
- depends = libmirage>=3.0.0
- source = https://github.com/kepstin/image-id/releases/download/v2.0.0/image-id-2.0.0.tar.gz
- sha256sums = 63164c26689c5b48d8f6621d08f1e0f45e8ac6107faba95ab8818b0fc66f6d77
+ depends = libmirage>=2.1.0
+ source = https://github.com/kepstin/image-id/releases/download/v2.1.0/image-id-2.1.0.tar.gz
+ sha256sums = 9ae16f4a938d351df5468e8d0ba732fde648dc4f1a1212e05d79ab312f8d7947
pkgname = image-id
diff --git a/PKGBUILD b/PKGBUILD
index 9c535394c911..f19e556b2407 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,15 @@
# Maintainer: Johannes Dewender arch at JonnyJD dot net
pkgname=image-id
-pkgver=2.0.0
+pkgver=2.1.0
pkgrel=1
pkgdesc="A tool to compute the MusicBrainz disc ID from a CD image"
arch=('x86_64' 'i686')
url="https://github.com/kepstin/image-id"
license=('GPL2')
-groups=()
-depends=('libdiscid' 'libmirage>=3.0.0')
-makedepends=()
+depends=('libdiscid' 'libmirage>=2.1.0')
options=()
source=(https://github.com/kepstin/image-id/releases/download/v$pkgver/$pkgname-${pkgver}.tar.gz)
-sha256sums=('63164c26689c5b48d8f6621d08f1e0f45e8ac6107faba95ab8818b0fc66f6d77')
+sha256sums=('9ae16f4a938d351df5468e8d0ba732fde648dc4f1a1212e05d79ab312f8d7947')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -19,10 +17,11 @@ prepare() {
build() {
cd "$srcdir/$pkgname-$pkgver"
- make CFLAGS="${CFLAGS} -Wall" LDFLAGS="${LDFLAGS}"
+ ./configure --prefix=/usr
+ make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- install -D image_id $pkgdir/usr/bin/image_id
+ make DESTDIR="$pkgdir/" install
}