summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2013-07-04 19:05:48 +0200
committerJohannes Dewender2013-07-04 19:05:48 +0200
commite0acb8b8540e16889ec55fae0bd7cd057622c8c5 (patch)
tree6cd11c64309ecdcf142cdd23955681f6fa200ad2
downloadaur-e0acb8b8540e16889ec55fae0bd7cd057622c8c5.tar.gz
image-id: create package from git master
No actual release was made yet. This is only there to test the distribution.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD29
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49a65142ba09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = image-id
+ pkgdesc = A tool to compute the MusicBrainz disc ID from a CD image
+ pkgver = master
+ pkgrel = 1
+ url = https://github.com/kepstin/image-id
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ depends = libdiscid
+ depends = libmirage>=2.0.0
+ source = image-id-master.zip::https://github.com/kepstin/image-id/archive/master.zip
+ md5sums = af5b62a60bf7015b36b670527a92d019
+
+pkgname = image-id
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd9b4a41adc0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.rpm
+*.zip
+*.bz2
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8052192169c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Johannes Dewender arch at JonnyJD dot net
+pkgname=image-id
+pkgver=master
+pkgrel=1
+pkgdesc="A tool to compute the MusicBrainz disc ID from a CD image"
+arch=('x86_64' 'i686')
+url="https://github.com/kepstin/image-id"
+license=('GPL2')
+groups=()
+depends=('libdiscid' 'libmirage>=2.0.0')
+makedepends=()
+options=()
+source=($pkgname-$pkgver.zip::https://github.com/kepstin/image-id/archive/master.zip)
+md5sums=('af5b62a60bf7015b36b670527a92d019')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e 's/CFLAGS=-g/CFLAGS += -g/' Makefile
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -D image_id $pkgdir/usr/bin/image_id
+}