summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-06-12 12:09:09 +0100
committermschubert2015-06-12 12:09:09 +0100
commitb5a2b007ed1b4f6c7484180e850981838356e222 (patch)
tree9861640771b79be856bc027317fb0deaa1b2d398
downloadaur-b5a2b007ed1b4f6c7484180e850981838356e222.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f5d4104d5d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = imagej-plugins-embl
+ pkgdesc = ImageJ plugin collection by the EMBL
+ pkgver = 20130120
+ pkgrel = 1
+ url = http://www.embl.de/almf/almf_services/services/downloads/imageJ/
+ arch = any
+ license = GPL
+ makedepends = unzip
+ depends = imagej
+ optdepends = java-environment
+ noextract = EMBL_ImageJ_plugins.zip
+ source = http://www.embl.de/download/almf/EMBL_ImageJ_plugins.zip
+ md5sums = 097f778d804c2506dbd8a1219267dc3b
+
+pkgname = imagej-plugins-embl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..180996ca1228
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+
+pkgname=imagej-plugins-embl
+_pkgname=EMBL_ImageJ_plugins
+pkgver=20130120
+pkgrel=1
+pkgdesc="ImageJ plugin collection by the EMBL"
+arch=('any')
+url="http://www.embl.de/almf/almf_services/services/downloads/imageJ/"
+license=('GPL')
+depends=('imagej')
+makedepends=('unzip')
+optdepends=('java-environment')
+source=("http://www.embl.de/download/almf/$_pkgname.zip")
+noextract=("$_pkgname.zip")
+md5sums=('097f778d804c2506dbd8a1219267dc3b')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/imagej"
+ unzip -d "$pkgdir/usr/share/imagej" "$srcdir/$_pkgname.zip"
+
+ # remove plugins already in standard distribution
+ rm "$pkgdir/usr/share/imagej/plugins/Particle Analysis/Cell_Counter.jar"
+ rm "$pkgdir/usr/share/imagej/plugins/Stacks - Z-functions/Volume_Viewer.jar"
+ rm "$pkgdir/usr/share/imagej/plugins/Exif_Reader.jar"
+}
+