summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-05-05 09:59:02 +0800
committerlilac2020-05-05 09:59:02 +0800
commitc4c8d3be589c9f34f5935cfef8b118d56f2e8727 (patch)
tree6d50cd9ed2c352a4c15947e6907c21bf85ae1ce3
parentd68c2b97eaaa4ba8ec9134f7d0fbf6e7fae07410 (diff)
downloadaur-c4c8d3be589c9f34f5935cfef8b118d56f2e8727.tar.gz
update by lilac
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--imagemagick-inkscape-1.0.patch13
3 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38305fc42fcc..17e204952ad3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = imagemagick-fftw
pkgdesc = An image viewing/manipulation program
pkgver = 7.0.10.10
- pkgrel = 1
+ pkgrel = 2
url = https://www.imagemagick.org/
arch = x86_64
license = custom
@@ -32,10 +32,12 @@ pkgbase = imagemagick-fftw
source = https://imagemagick.org/download/ImageMagick-7.0.10-10.tar.xz
source = https://imagemagick.org/download/ImageMagick-7.0.10-10.tar.xz.asc
source = arch-fonts.diff
+ source = imagemagick-inkscape-1.0.patch
validpgpkeys = D8272EF51DA223E4D05B466989AB63D48277377A
sha256sums = df1a37b73aa49423abb422c2150a0e1436920ba50dfc4377c6a3793f9826e5f1
sha256sums = SKIP
sha256sums = a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73
+ sha256sums = c84c7baea1d2397a57a19b3adb8f98fe1c723d55792101ecb3b806320dd28f77
pkgname = imagemagick-fftw
depends = libltdl
diff --git a/PKGBUILD b/PKGBUILD
index a83b155b74a5..7842daba3230 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=imagemagick-fftw
pkgname=(imagemagick-fftw)
pkgver=7.0.10.10
-pkgrel=1
+pkgrel=2
pkgdesc="An image viewing/manipulation program"
url="https://www.imagemagick.org/"
arch=(x86_64)
@@ -15,10 +15,12 @@ checkdepends=(gsfonts ttf-dejavu)
_relname=ImageMagick-${pkgver%%.*}
_tarname=ImageMagick-${pkgver%.*}-${pkgver##*.}
source=(https://imagemagick.org/download/$_tarname.tar.xz{,.asc}
- arch-fonts.diff)
+ arch-fonts.diff
+ imagemagick-inkscape-1.0.patch)
sha256sums=('df1a37b73aa49423abb422c2150a0e1436920ba50dfc4377c6a3793f9826e5f1'
'SKIP'
- 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73')
+ 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73'
+ 'c84c7baea1d2397a57a19b3adb8f98fe1c723d55792101ecb3b806320dd28f77')
validpgpkeys=(D8272EF51DA223E4D05B466989AB63D48277377A) # Lexie Parsimoniae
shopt -s extglob
@@ -30,6 +32,9 @@ prepare() {
# Fix up typemaps to match our packages, where possible
patch -p1 -i ../arch-fonts.diff
+
+ # Use correct parameter for inkscape 1.0
+ patch -p1 -i ../imagemagick-inkscape-1.0.patch
}
build() {
@@ -106,8 +111,5 @@ package_imagemagick-fftw() {
# Harden security policy https://bugs.archlinux.org/task/62785
sed -e '/<\/policymap>/i \ \ <policy domain="delegate" rights="none" pattern="gs" \/>' -i "$pkgdir"/etc/ImageMagick-7/policy.xml
-
-# Use correct options for inkscape<1.0
- sed -e 's|--export-file|--export-png|' -i "$pkgdir"/etc/ImageMagick-7/delegates.xml
}
diff --git a/imagemagick-inkscape-1.0.patch b/imagemagick-inkscape-1.0.patch
new file mode 100644
index 000000000000..bd3ba5acc60e
--- /dev/null
+++ b/imagemagick-inkscape-1.0.patch
@@ -0,0 +1,13 @@
+diff --git a/config/delegates.xml.in b/config/delegates.xml.in
+index 442fa1aca..19baaee91 100644
+--- a/config/delegates.xml.in
++++ b/config/delegates.xml.in
+@@ -111,7 +111,7 @@
+ <delegate decode="sid" command="&quot;@MrSIDDecodeDelegate@&quot; -if sid -i &quot;%i&quot; -of tif -o &quot;%o&quot; &gt; &quot;%u&quot;"/>
+ <delegate decode="svg" command="&quot;@RSVGDecodeDelegate@&quot; -o &quot;%o&quot; &quot;%i&quot;"/>
+ <!-- Change export-png to export-file for inkscape >= 1.0 -->
+- <delegate decode="svg:decode" stealth="True" command="&quot;@SVGDecodeDelegate@&quot; &quot;%s&quot; --export-png=&quot;%s&quot; --export-dpi=&quot;%s&quot; --export-background=&quot;%s&quot; --export-background-opacity=&quot;%s&quot; &gt; &quot;%s&quot; 2&gt;&amp;1"/>
++ <delegate decode="svg:decode" stealth="True" command="&quot;@SVGDecodeDelegate@&quot; &quot;%s&quot; --export-filename=&quot;%s&quot; --export-dpi=&quot;%s&quot; --export-background=&quot;%s&quot; --export-background-opacity=&quot;%s&quot; &gt; &quot;%s&quot; 2&gt;&amp;1"/>
+ <delegate decode="tiff" encode="launch" mode="encode" command="&quot;@LaunchDelegate@&quot; &quot;%i&quot;"/>
+ <delegate decode="wdp" command="@MVDelegate@ &quot;%i&quot; &quot;%i.jxr&quot;; &quot;@JXRDecodeDelegate@&quot; -i &quot;%i.jxr&quot; -o &quot;%o.bmp&quot;; @MVDelegate@ &quot;%i.jxr&quot; &quot;%i&quot;; @MVDelegate@ &quot;%o.bmp&quot; &quot;%o&quot;"/>
+ <delegate decode="webp" command="&quot;@WebPDecodeDelegate@&quot; -pam &quot;%i&quot; -o &quot;%o&quot;"/>