summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-09-26 19:47:59 -0300
committerDaniel Bermond2022-09-26 19:47:59 -0300
commit1c709e51f05f2c50dd1c9336f222906e066fc6dc (patch)
tree56ba8bf252015c40ce9ec50148395b5476449420
parent07ec2e3a6a3a0d535e845cb27590668f0c00da0d (diff)
downloadaur-1c709e51f05f2c50dd1c9336f222906e066fc6dc.tar.gz
Update to version 7.1.0.49
Disabled tcmalloc due to memory leak in client applications comming from 'libtcmalloc_minimal.so'.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffd9df488f7d..8555cbfb8785 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = imagemagick-full
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all possible features)
- pkgver = 7.1.0.48
+ pkgver = 7.1.0.49
pkgrel = 1
url = https://www.imagemagick.org/
arch = x86_64
@@ -27,7 +27,6 @@ pkgbase = imagemagick-full
makedepends = zlib
makedepends = libltdl
makedepends = djvulibre
- makedepends = gperftools
makedepends = libraw
makedepends = graphviz
makedepends = openexr
@@ -56,11 +55,11 @@ pkgbase = imagemagick-full
makedepends = flif
makedepends = libfpx
makedepends = libumem-git
- source = https://imagemagick.org/archive/releases/ImageMagick-7.1.0-48.tar.xz
- source = https://imagemagick.org/archive/releases/ImageMagick-7.1.0-48.tar.xz.asc
+ source = https://imagemagick.org/archive/releases/ImageMagick-7.1.0-49.tar.xz
+ source = https://imagemagick.org/archive/releases/ImageMagick-7.1.0-49.tar.xz.asc
source = arch-fonts.diff
validpgpkeys = D8272EF51DA223E4D05B466989AB63D48277377A
- sha256sums = eb2d4dc3cc9fd3d4686aa64562177ca5067b1d40bcb6ec75fa1003eaf8c37f4e
+ sha256sums = ff55aabc66bb1e110979acc526287185188541ea265e796c2e4b1cb2d81b4ecf
sha256sums = SKIP
sha256sums = 290c6a87845b419459fb552c0e7dcd81fbeafcecc370818d442fedf4d315b7fb
@@ -77,7 +76,6 @@ pkgname = imagemagick-full
depends = bzip2
depends = zlib
depends = libltdl
- depends = gperftools
depends = djvulibre
depends = libraw
depends = graphviz
@@ -107,9 +105,9 @@ pkgname = imagemagick-full
depends = libfpx
depends = libumem-git
optdepends = imagemagick-full-doc: manual and API docs
- provides = imagemagick=7.1.0.48
- provides = libmagick=7.1.0.48
- provides = libmagick-full=7.1.0.48
+ provides = imagemagick=7.1.0.49
+ provides = libmagick=7.1.0.49
+ provides = libmagick-full=7.1.0.49
conflicts = imagemagick
conflicts = libmagick
replaces = libmagick-full
@@ -132,5 +130,5 @@ pkgname = imagemagick-full
pkgname = imagemagick-full-doc
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all possible features) (manual and API docs)
arch = any
- provides = imagemagick-doc=7.1.0.48
+ provides = imagemagick-doc=7.1.0.49
conflicts = imagemagick-doc
diff --git a/PKGBUILD b/PKGBUILD
index 29bb05a6d66d..7a5d1abdc128 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@
pkgbase=imagemagick-full
pkgname=('imagemagick-full' 'imagemagick-full-doc')
-pkgver=7.1.0.48
+pkgver=7.1.0.49
pkgrel=1
arch=('x86_64')
_qdepth='32'
@@ -25,7 +25,7 @@ makedepends=(
'perl' 'jbigkit' 'opencl-headers' 'glu' 'ghostpcl' 'ghostxps'
'zstd' 'chrpath' 'xorgproto'
'lcms2' 'libraqm' 'liblqr' 'fftw' 'libxml2' 'fontconfig' 'freetype2' 'libxext'
- 'libx11' 'bzip2' 'zlib' 'libltdl' 'djvulibre' 'gperftools' 'libraw'
+ 'libx11' 'bzip2' 'zlib' 'libltdl' 'djvulibre' 'libraw'
'graphviz' 'openexr' 'libheif' 'openjpeg2' 'libjpeg-turbo' 'xz' 'glib2' 'pango'
'cairo' 'libpng' 'ghostscript' 'ming' 'librsvg' 'libtiff' 'libwebp' 'libwmf'
'ocl-icd' 'gsfonts' 'ttf-dejavu' 'perl' 'libzip' 'libjxl' 'highway'
@@ -34,7 +34,7 @@ makedepends=(
)
source=("https://imagemagick.org/archive/releases/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz"{,.asc}
'arch-fonts.diff')
-sha256sums=('eb2d4dc3cc9fd3d4686aa64562177ca5067b1d40bcb6ec75fa1003eaf8c37f4e'
+sha256sums=('ff55aabc66bb1e110979acc526287185188541ea265e796c2e4b1cb2d81b4ecf'
'SKIP'
'290c6a87845b419459fb552c0e7dcd81fbeafcecc370818d442fedf4d315b7fb')
validpgpkeys=('D8272EF51DA223E4D05B466989AB63D48277377A') # Lexie Parsimoniae
@@ -67,7 +67,7 @@ build() {
--with-perl \
--with-perl-options='INSTALLDIRS=vendor' \
--without-jemalloc \
- --with-tcmalloc \
+ --without-tcmalloc \
--with-umem \
--with-bzlib \
--with-x \
@@ -123,7 +123,7 @@ package_imagemagick-full() {
depends=(
# official repositories:
'lcms2' 'libraqm' 'liblqr' 'fftw' 'libxml2' 'fontconfig' 'freetype2' 'libxext'
- 'libx11' 'bzip2' 'zlib' 'libltdl' 'gperftools' 'djvulibre' 'libraw'
+ 'libx11' 'bzip2' 'zlib' 'libltdl' 'djvulibre' 'libraw'
'graphviz' 'openexr' 'libheif' 'openjpeg2' 'libjpeg-turbo' 'xz' 'glib2' 'pango'
'cairo' 'libpng' 'ghostscript' 'ming' 'librsvg' 'libtiff' 'libwebp' 'libwmf'
'ocl-icd' 'gsfonts' 'ttf-dejavu' 'perl' 'libzip' 'libjxl'