summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBermond2016-02-14 01:48:47 -0200
committerBermond2016-02-14 01:48:47 -0200
commit795b49e63daa32cdc6489f5ef56826fa7c5d227c (patch)
tree3717fdc284db6dcce5e73ca45070514efd2f0a8e
downloadaur-795b49e63daa32cdc6489f5ef56826fa7c5d227c.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..638b35216535
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Feb 14 03:48:36 UTC 2016
+pkgbase = imagemagick-full-doc-git
+ pkgdesc = The ImageMagick documentation (utilities manuals and libraries API)
+ pkgver = 7.0.0.0.r10577.g0ff89d1
+ pkgrel = 1
+ url = http://www.imagemagick.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ provides = imagemagick-doc
+ provides = imagemagick-full-doc
+ provides = imagemagick-git-doc
+ conflicts = imagemagick-doc
+ conflicts = imagemagick-full-doc
+ conflicts = imagemagick-git-doc
+ source = imagemagick-full-doc-git::git+http://git.imagemagick.org/repos/ImageMagick.git
+ sha256sums = SKIP
+
+pkgname = imagemagick-full-doc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..74d4e5f896c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
+
+pkgname=imagemagick-full-doc-git
+pkgver=7.0.0.0.r10577.g0ff89d1
+pkgrel=1
+pkgdesc="The ImageMagick documentation (utilities manuals and libraries API)"
+arch=('i686' 'x86_64')
+url="http://www.imagemagick.org/"
+license=('custom')
+provides=('imagemagick-doc' 'imagemagick-full-doc' 'imagemagick-git-doc')
+conflicts=('imagemagick-doc' 'imagemagick-full-doc' 'imagemagick-git-doc')
+source=("$pkgname"::'git+http://git.imagemagick.org/repos/ImageMagick.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+
+ # Git, no tags available
+
+ local _version="$(grep "PACKAGE_VERSION=" version.sh | grep -o '[0-9.]*')"
+ local _release="$(grep "PACKAGE_RELEASE=" version.sh | grep -o '[0-9]')"
+ local _revision="$(printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")"
+
+ printf "%s.%s.%s" "$_version" "$_release" "$_revision"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ make DESTDIR="$pkgdir/" install-data-html
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 NOTICE "${pkgdir}/usr/share/licenses/${pkgname}/NOTICE"
+}