summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBermond2016-06-03 23:06:16 -0300
committerBermond2016-06-03 23:06:16 -0300
commitcdd2bf156bf22b93d16af034c64840a2e0b67912 (patch)
treeb608ab4028ddac25c8d4916ee9c0c8b192d1d640
parent5cefba18230ff14226422320848cd8420a93d90e (diff)
downloadaur-cdd2bf156bf22b93d16af034c64840a2e0b67912.tar.gz
Fixed pkgver() to avoid errors
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 348bc1cb3ba9..2daadc59e4ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat May 7 23:22:03 UTC 2016
+# Sat Jun 4 02:06:12 UTC 2016
pkgbase = imagemagick-full-git
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all libs and features, Git version)
- pkgver = 7.0.1.2.r10838.ga58ba05
+ pkgver = 7.0.1.10.r10954.g83bceaa
pkgrel = 1
url = http://www.imagemagick.org/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 9137f035cb92..faa638c1663b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _dejavu_font_dir="/usr/share/fonts/TTF"
_gs_font_dir="/usr/share/fonts/Type1"
_windows_font_dir="/usr/share/fonts/WindowsFonts"
pkgname=imagemagick-full-git
-pkgver=7.0.1.2.r10838.ga58ba05
+pkgver=7.0.1.10.r10954.g83bceaa
pkgrel=1
pkgdesc="An image viewing/manipulation program (Q32 HDRI with all libs and features, Git version)"
arch=('i686' 'x86_64')
@@ -52,8 +52,8 @@ pkgver() {
# Git, no tags available
- local _version="$(grep "PACKAGE_VERSION=" version.sh | grep -o '[0-9.]*')"
- local _release="$(grep "PACKAGE_RELEASE=" version.sh | grep -o '[0-9]')"
+ local _version="$(grep "PACKAGE_VERSION=" ./version.sh | sed 's/[^0-9\.]*//g')"
+ local _release="$(grep "PACKAGE_RELEASE=" ./version.sh | sed 's/[^0-9]*//g')"
local _revision="$(printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")"
printf "%s.%s.%s" "$_version" "$_release" "$_revision"