summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManjaro Build Server2023-03-29 10:55:46 -0600
committerManjaro Build Server2023-03-29 10:55:46 -0600
commit156b17cd28c8321881106870b684c0051e6418e2 (patch)
tree069e3921de3f105f68345de24b6a871baee11c00
parent15f3d3fb487fc8c857fcbe9041694e20677943be (diff)
downloadaur-156b17cd28c8321881106870b684c0051e6418e2.tar.gz
restore libmagick6 package to avoid conflicts with imagemagick
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD52
2 files changed, 42 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83b937cfcaa8..74a12b11ba4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = imagemagick6
pkgdesc = An image viewing/manipulation program (legacy 6.9.12-* series)
pkgver = 6.9.12.83
- pkgrel = 2
+ pkgrel = 3
url = https://legacy.imagemagick.org/
arch = x86_64
license = custom
@@ -39,6 +39,16 @@ pkgbase = imagemagick6
depends = libraqm
depends = libpng
depends = libxml2
+ source = https://legacy.imagemagick.org/archive/releases/ImageMagick-6.9.12-83.tar.gz
+ source = https://legacy.imagemagick.org/archive/releases/ImageMagick-6.9.12-83.tar.gz.asc
+ source = arch-fonts.diff
+ validpgpkeys = D8272EF51DA223E4D05B466989AB63D48277377A
+ sha256sums = e3af62a54a3286ac78ce5ec1860389293b27f353582d854d181fb2ea2ee4f147
+ sha256sums = SKIP
+ sha256sums = a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73
+
+pkgname = libmagick6
+ pkgdesc = An image viewing/manipulation program (legacy 6.9.12-* series; library)
optdepends = ghostscript: PS/PDF support
optdepends = libheif: HEIF support
optdepends = libjxl: JPEG XL support
@@ -52,7 +62,6 @@ pkgbase = imagemagick6
optdepends = openjpeg2: JPEG2000 support
optdepends = djvulibre: DJVU support
optdepends = pango: Text rendering
- provides = libmagick6
options = !emptydirs
options = libtool
backup = etc/ImageMagick-6/coder.xml
@@ -67,12 +76,3 @@ pkgbase = imagemagick6
backup = etc/ImageMagick-6/type.xml
backup = etc/ImageMagick-6/type-dejavu.xml
backup = etc/ImageMagick-6/type-ghostscript.xml
- source = https://legacy.imagemagick.org/archive/releases/ImageMagick-6.9.12-83.tar.gz
- source = https://legacy.imagemagick.org/archive/releases/ImageMagick-6.9.12-83.tar.gz.asc
- source = arch-fonts.diff
- validpgpkeys = D8272EF51DA223E4D05B466989AB63D48277377A
- sha256sums = e3af62a54a3286ac78ce5ec1860389293b27f353582d854d181fb2ea2ee4f147
- sha256sums = SKIP
- sha256sums = a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73
-
-pkgname = imagemagick6
diff --git a/PKGBUILD b/PKGBUILD
index cd67381e75a2..c861d75a31e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,11 @@
# Contributor: bartus <arch-user-repoᘓbartus.33mail.com>
# Contributor: Eric Bélanger <eric@archlinux.org>
-pkgname=imagemagick6
+pkgname=libmagick6
+pkgbase=imagemagick6
_pkgver=6.9.12-83
pkgver=${_pkgver//-/.}
-pkgrel=2
+pkgrel=3
pkgdesc="An image viewing/manipulation program (legacy 6.9.12-* series)"
url="https://legacy.imagemagick.org/"
arch=('x86_64')
@@ -14,23 +15,7 @@ license=('custom')
depends=('libltdl' 'lcms2' 'fontconfig' 'libxext' 'liblqr' 'libraqm' 'libpng' 'libxml2')
makedepends=('ghostscript' 'openexr' 'libwmf' 'librsvg' 'libxml2' 'openjpeg2' 'libraw' 'opencl-headers' 'libwebp' 'libzip' 'libjxl'
'chrpath' 'ocl-icd' 'glu' 'ghostpcl' 'ghostxps' 'libheif' 'jbigkit' 'lcms2' 'libxext' 'liblqr' 'libraqm' 'libpng' 'djvulibre')
-optdepends=('ghostscript: PS/PDF support'
- 'libheif: HEIF support'
- 'libjxl: JPEG XL support'
- 'libraw: DNG support'
- 'librsvg: SVG support'
- 'libwebp: WEBP support'
- 'libwmf: WMF support'
- 'libxml2: Magick Scripting Language'
- 'ocl-icd: OpenCL support'
- 'openexr: OpenEXR support'
- 'openjpeg2: JPEG2000 support'
- 'djvulibre: DJVU support'
- 'pango: Text rendering')
checkdepends=('gsfonts' 'ttf-dejavu')
-options=('!emptydirs' 'libtool')
-backup=(etc/ImageMagick-6/{coder,colors,delegates,log,magic,mime,policy,quantization-table,thresholds,type,type-{dejavu,ghostscript}}.xml)
-provides=('libmagick6')
source=("https://legacy.imagemagick.org/archive/releases/ImageMagick-$_pkgver.tar.gz"{,.asc}
'arch-fonts.diff')
sha256sums=('e3af62a54a3286ac78ce5ec1860389293b27f353582d854d181fb2ea2ee4f147'
@@ -41,7 +26,7 @@ validpgpkeys=('D8272EF51DA223E4D05B466989AB63D48277377A') # Lexie Parsimoniae (I
shopt -s extglob
prepare() {
- mkdir -p docpkg/usr/share
+ mkdir -p binpkg/usr/lib/pkgconfig {binpkg,docpkg}/usr/share
cd ImageMagick-$_pkgver
@@ -96,13 +81,38 @@ check() (
make check || :
)
-package() {
+package_libmagick6() {
+ pkgdesc="${pkgdesc/)/; library)}"
+ optdepends=('ghostscript: PS/PDF support'
+ 'libheif: HEIF support'
+ 'libjxl: JPEG XL support'
+ 'libraw: DNG support'
+ 'librsvg: SVG support'
+ 'libwebp: WEBP support'
+ 'libwmf: WMF support'
+ 'libxml2: Magick Scripting Language'
+ 'ocl-icd: OpenCL support'
+ 'openexr: OpenEXR support'
+ 'openjpeg2: JPEG2000 support'
+ 'djvulibre: DJVU support'
+ 'pango: Text rendering')
+ options=('!emptydirs' 'libtool')
+ backup=(etc/ImageMagick-6/{coder,colors,delegates,log,magic,mime,policy,quantization-table,thresholds,type,type-{dejavu,ghostscript}}.xml)
+
cd ImageMagick-$_pkgver
make DESTDIR="$pkgdir" install pkgconfigdir="/usr/lib/$pkgbase/pkgconfig"
- find "$pkgdir/usr/lib/perl5" -name '*.so' -exec chrpath -d {} +
rm "$pkgdir"/etc/ImageMagick-6/type-{apple,urw-base35,windows}.xml
rm "$pkgdir"/usr/lib/*.la
install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE NOTICE
+
+ # Drop tools
+ cd ../binpkg
+ mv "$pkgdir/usr/bin" usr/
+ mv "$pkgdir/usr/lib/perl5" usr/lib/
+ mv "$pkgdir/usr/share/man" usr/share/
+
+ # Harden security policy https://bugs.archlinux.org/task/62785
+ sed -e '/<\/policymap>/i \ \ <policy domain="delegate" rights="none" pattern="gs" \/>' -i "$pkgdir"/etc/ImageMagick-6/policy.xml
}