summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBermond2016-08-14 17:47:15 -0300
committerBermond2016-08-14 17:47:15 -0300
commit412d1a03cd4308edceb5f63b52908da2b1d0f560 (patch)
tree1ca0c55d34bb3615283bc5c4bf76c2391ea83a80
parent8779610a10c17519c5981b74899a9fed021d3e47 (diff)
downloadaur-412d1a03cd4308edceb5f63b52908da2b1d0f560.tar.gz
Updated to version 7.0.2.8
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD12
-rw-r--r--imagemagick-7.0.2.8-opencl-compile-fix.patch30
3 files changed, 46 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8aa2cda6780d..b99bf6f645a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Aug 7 23:56:12 UTC 2016
+# Sun Aug 14 20:46:24 UTC 2016
pkgbase = imagemagick-full
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all libs and features)
- pkgver = 7.0.2.7
+ pkgver = 7.0.2.8
pkgrel = 1
url = http://www.imagemagick.org/
arch = i686
@@ -71,8 +71,10 @@ pkgbase = imagemagick-full
backup = etc/ImageMagick-7/type-dejavu.xml
backup = etc/ImageMagick-7/type-ghostscript.xml
backup = etc/ImageMagick-7/type-windows.xml
- source = http://www.imagemagick.org/download/ImageMagick-7.0.2-7.tar.xz
- sha256sums = 1168f44cfcd1243acda6bb9663f5d9b3a4bca2acd372e979b97b58ecf5c713e2
+ source = http://www.imagemagick.org/download/ImageMagick-7.0.2-8.tar.xz
+ source = imagemagick-7.0.2.8-opencl-compile-fix.patch
+ sha256sums = 60a2e6811a70612217b2a66a345c6073c6e220a481ce2f5db43fccc5232eb668
+ sha256sums = 82e04d016cd9154f7d6edc4a2cb6dad9b226e9cd44116bb48723da3cb2c5fe9b
pkgname = imagemagick-full
diff --git a/PKGBUILD b/PKGBUILD
index c8d993344448..0f4ea60fe987 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -56,8 +56,16 @@ backup=("etc/ImageMagick-${pkgver%%.*}/coder.xml"
"etc/ImageMagick-${pkgver%%.*}/type-ghostscript.xml"
"etc/ImageMagick-${pkgver%%.*}/type-windows.xml")
options=('!docs' 'libtool' '!emptydirs')
-source=("http://www.imagemagick.org/download/${_srcname}-${_srcver}.tar.xz")
-sha256sums=($(curl -s ${_digest} | grep -A5 "${_srcname}-${_srcverregex}\.tar\.xz" | grep 'sha256' | grep -oE '>[[:alnum:]]*?<' | sed 's/[><]//g'))
+source=("http://www.imagemagick.org/download/${_srcname}-${_srcver}.tar.xz"
+ 'imagemagick-7.0.2.8-opencl-compile-fix.patch'
+)
+sha256sums=('60a2e6811a70612217b2a66a345c6073c6e220a481ce2f5db43fccc5232eb668'
+ '82e04d016cd9154f7d6edc4a2cb6dad9b226e9cd44116bb48723da3cb2c5fe9b')
+
+prepare() {
+ cd "$_srcname"-"$_srcver"
+ patch -p1 -i ../imagemagick-7.0.2.8-opencl-compile-fix.patch
+}
build() {
cd "$_srcname"-"$_srcver"
diff --git a/imagemagick-7.0.2.8-opencl-compile-fix.patch b/imagemagick-7.0.2.8-opencl-compile-fix.patch
new file mode 100644
index 000000000000..5ccc52de780e
--- /dev/null
+++ b/imagemagick-7.0.2.8-opencl-compile-fix.patch
@@ -0,0 +1,30 @@
+diff --git a/MagickCore/opencl.c b/MagickCore/opencl.c
+index 6f16996..b8656a2 100644
+--- a/MagickCore/opencl.c
++++ b/MagickCore/opencl.c
+@@ -725,16 +725,12 @@ static void LoadOpenCLDeviceBenchmark(MagickCLEnv clEnv,const char *xml)
+ MagickCLDeviceBenchmark
+ *device_benchmark;
+
+- MagickStatusType
+- status;
+-
+ size_t
+ i,
+ extent;
+
+ if (xml == (char *) NULL)
+ return;
+- status=MagickTrue;
+ device_benchmark=(MagickCLDeviceBenchmark *) NULL;
+ token=AcquireString(xml);
+ extent=strlen(token)+MagickPathExtent;
+@@ -919,7 +915,7 @@ static MagickBooleanType LoadOpenCLBenchmarks(MagickCLEnv clEnv,
+ return(MagickFalse);
+ }
+
+- option=ConfigureFileToStringInfo(filename,exception);
++ option=ConfigureFileToStringInfo(filename);
+ LoadOpenCLDeviceBenchmark(clEnv,(const char *) GetStringInfoDatum(option));
+ option=DestroyStringInfo(option);
+ return(MagickTrue);