summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBermond2016-07-09 12:23:57 -0300
committerBermond2016-07-09 12:23:57 -0300
commitc2a8767c8b15f04aa9e602b8ea1eaa618e9ae3c6 (patch)
tree2f591f7677d4865ac698534a80972d11e441c431
parenta46f5d816d08ff217d532bfc7a60f7fd8d4120df (diff)
downloadaur-c2a8767c8b15f04aa9e602b8ea1eaa618e9ae3c6.tar.gz
Added Apple fonts support (optional due to licensing issues)
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD11
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 938b6b1e3dbb..2d44e8d8fd01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,7 @@
pkgbase = imagemagick-full
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all libs and features)
pkgver = 7.0.2.2
- pkgrel = 3
+ pkgrel = 4
url = http://www.imagemagick.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9e2b18f29485..b86458275ca1 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,17 +13,21 @@
# This Windows font directory example is for people that copy/link fonts from a Windows
# installation. If you prefer, you can choose an AUR package that provides the Windows fonts
# as described in the Wiki and change the directory accordingly.
+# Apple fonts through AUR package 'tff-mac-fonts' are optional due to licensing issues. It
+# places fonts in directories '/usr/share/fonts/TTF' and '/usr/share/fonts/Type1'.
_dejavu_font_dir="/usr/share/fonts/TTF"
_gs_font_dir="/usr/share/fonts/Type1"
_windows_font_dir="/usr/share/fonts/WindowsFonts"
+_1st_apple_font_dir="/usr/share/fonts/TTF"
+_2nd_apple_font_dir="/usr/share/fonts/Type1"
_digest="http://www.imagemagick.org/download/digest.rdf"
_srcname="ImageMagick"
_srcver=$(curl -s "$_digest" | grep -o "${_srcname}-7[0-9\.-]*\.tar\.xz" | sed 's/[^0-9\.-]*//g' | sed -r 's/.//;s/.{2}$//')
_srcverregex=$(echo "$_srcver" | sed 's/\./\\\./g') # translate source version to a regular expression
pkgname=imagemagick-full
pkgver=$(echo "$_srcver" | tr '-' '.')
-pkgrel=3
+pkgrel=4
pkgdesc="An image viewing/manipulation program (Q32 HDRI with all libs and features)"
arch=('i686' 'x86_64')
url="http://www.imagemagick.org/"
@@ -32,6 +36,7 @@ depends=('jemalloc' 'bzip2' 'libx11' 'libxext' 'libxt' 'libsm' 'zlib' 'autotrace
'libfpx' 'djvulibre' 'ttf-dejavu' 'fontconfig' 'freetype2' 'libraqm' 'ghostscript' 'gsfonts'
'graphviz' 'jbigkit' 'libjpeg-turbo' 'lcms' 'lcms2' 'openjpeg2' 'liblqr' 'xz' 'openexr' 'pango'
'libpng' 'librsvg' 'libtiff' 'libwebp' 'libwmf' 'libxml2' 'libmpeg2' 'opencl-headers' 'ocl-icd')
+optdepends=('ttf-mac-fonts: for Apple fonts support')
provides=("imagemagick"
"libMagickCore-${pkgver%%.*}.Q32HDRI.so"
"libMagickWand-${pkgver%%.*}.Q32HDRI.so"
@@ -110,7 +115,9 @@ build() {
--with-xml \
--with-dejavu-font-dir="$_dejavu_font_dir" \
--with-gs-font-dir="$_gs_font_dir" \
- --with-windows-font-dir="$_windows_font_dir"
+ --with-windows-font-dir="$_windows_font_dir" \
+ --with-apple-font-dir="$_1st_apple_font_dir" \
+ --with-fontpath="$_2nd_apple_font_dir"
make
}