summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBermond2016-02-14 01:58:41 -0200
committerBermond2016-02-14 01:58:41 -0200
commitff8bdc453970a76a1397da1b6caf693406378d65 (patch)
treec6b889aa80857d3a140ec220218ad13db80181d8
parentc178ed5ed4ba1fbfd24ebc4dace5ef4c4c3ca5f0 (diff)
downloadaur-ff8bdc453970a76a1397da1b6caf693406378d65.tar.gz
Added some explicit options. Added tab spaces.
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD105
2 files changed, 58 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea4e0d6cccc8..b7108ea52c89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Feb 13 22:27:26 UTC 2016
+# Sun Feb 14 03:57:59 UTC 2016
pkgbase = imagemagick-full
pkgdesc = An image viewing/manipulation program (Q32 HDRI with all libs and features)
pkgver = 6.9.3.4
- pkgrel = 2
+ pkgrel = 3
url = http://www.imagemagick.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b9d04b148b9c..40c7e15404d2 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ _srcname="ImageMagick"
_srcver="6.9.3-4"
pkgname=imagemagick-full
pkgver="$(echo ${_srcver} | tr '-' '.')"
-pkgrel=2
+pkgrel=3
pkgdesc="An image viewing/manipulation program (Q32 HDRI with all libs and features)"
arch=('i686' 'x86_64')
url="http://www.imagemagick.org/"
@@ -49,61 +49,68 @@ sha256sums=('0d4266940d27afb617fc8b3481ffdf63dd02ca13806d581ac5cb28638725c275')
build() {
cd "$_srcname"-"$_srcver"
-
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --enable-static=no \
- --enable-shared=yes \
- --enable-opencl \
- --enable-hdri \
- --enable-hugepages \
- --disable-delegate-build \
- --with-modules \
- --with-quantum-depth=32 \
- --with-magick-plus-plus \
- --with-perl \
- --with-perl-options="INSTALLDIRS=vendor" \
- --with-jemalloc \
- --with-umem \
- --with-bzlib \
- --with-x \
- --with-zlib \
- --with-autotrace \
- --without-dps \
- --with-fftw \
- --with-fpx \
- --with-djvu \
- --with-fontconfig \
- --with-freetype \
- --with-gslib \
- --with-gvc \
- --with-jbig \
- --with-jpeg \
- --with-lcms \
- --with-openjp2 \
- --with-lqr \
- --with-lzma \
- --with-openexr \
- --with-pango \
- --with-png \
- --with-rsvg \
- --with-tiff \
- --with-webp \
- --with-wmf \
- --with-xml \
- --with-dejavu-font-dir="$_dejavu_font_dir" \
- --with-gs-font-dir="$_gs_font_dir" \
- --with-windows-font-dir="$_windows_font_dir"
+
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-static=no \
+ --enable-shared=yes \
+ --enable-fast-install=yes \
+ --enable-openmp \
+ --enable-opencl \
+ --enable-largefile \
+ --enable-cipher \
+ --enable-hdri \
+ --enable-hugepages \
+ --enable-docs \
+ --disable-delegate-build \
+ --with-threads \
+ --with-modules \
+ --with-quantum-depth=32 \
+ --with-magick-plus-plus \
+ --with-perl \
+ --with-perl-options="INSTALLDIRS=vendor" \
+ --with-jemalloc \
+ --with-umem \
+ --with-bzlib \
+ --with-x \
+ --with-zlib \
+ --with-autotrace \
+ --without-dps \
+ --with-fftw \
+ --with-fpx \
+ --with-djvu \
+ --with-fontconfig \
+ --with-freetype \
+ --with-gslib \
+ --with-gvc \
+ --with-jbig \
+ --with-jpeg \
+ --with-lcms \
+ --with-openjp2 \
+ --with-lqr \
+ --with-lzma \
+ --with-openexr \
+ --with-pango \
+ --with-png \
+ --with-rsvg \
+ --with-tiff \
+ --with-webp \
+ --with-wmf \
+ --with-xml \
+ --with-dejavu-font-dir="$_dejavu_font_dir" \
+ --with-gs-font-dir="$_gs_font_dir" \
+ --with-windows-font-dir="$_windows_font_dir"
+
make
}
package() {
-
cd "$_srcname"-"$_srcver"
make -j1 DESTDIR="$pkgdir/" install
+
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/${pkgname}/NOTICE"
-
}