summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoolspub2016-03-23 19:59:22 +0100
committerRoolspub2016-03-23 19:59:22 +0100
commit2defc89e7cbf56bfdd29d17ab143440a25f85fdf (patch)
tree6d3cc4bf44c1758d7deeef0b8bbd2f1bf2257405
downloadaur-imdbpy-git.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b1faba1e3af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = imdbpy-git
+ pkgdesc = Python bindings for the Internet Movie Database (IMDb)
+ pkgver = 5.0.22.gc4137d9
+ pkgrel = 1
+ url = http://imdbpy.sourceforge.net/
+ arch = any
+ license = GPL
+ depends = python2
+ provides = imdbpy
+ replaces = imdbpy
+ options = !emptydirs
+ source = imdbpy::git+https://github.com/alberanid/imdbpy.git
+ md5sums = SKIP
+
+pkgname = imdbpy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2193c078ec89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Roolspub <roolspub@laposte.net>
+pkgname=imdbpy-git
+pkgrel=1
+pkgver=5.0.22.gc4137d9
+pkgdesc="Python bindings for the Internet Movie Database (IMDb)"
+arch=('any')
+url="http://imdbpy.sourceforge.net/"
+license=('GPL')
+depends=('python2')
+provides=('imdbpy')
+replaces=('imdbpy')
+options=(!emptydirs)
+source=('imdbpy::git+https://github.com/alberanid/imdbpy.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "imdbpy"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/imdbpy"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+