summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorozgursarier2015-09-15 01:15:46 +0300
committerozgursarier2015-09-15 01:15:46 +0300
commit08badbd7460682b72925f54273963701b3eb1fd1 (patch)
treed2337a982ac124eee4ed51e39d20c07e442d9b66
downloadaur-08badbd7460682b72925f54273963701b3eb1fd1.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3f610dfbaed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = img2pdf-git
+ pkgdesc = Losslessly convert images to PDF without unnecessarily re-encoding JPEG and JPEG2000 files. Image quality is retained without unnecessarily increasing file size.
+ pkgver = 0.1.6-git
+ pkgrel = 1
+ url = https://gitlab.mister-muffin.de/josch/img2pdf
+ arch = any
+ license = LGPL3
+ makedepends = git
+ depends = python
+ depends = python-pillow
+ depends = python-setuptools
+ provides = img2pdf=0.1.6-git
+ conflicts = img2pdf
+ options = !emptydirs
+ source = git+http://gitlab.mister-muffin.de/josch/img2pdf.git
+ md5sums = SKIP
+
+pkgname = img2pdf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c33acc3568b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
+
+_name=img2pdf
+pkgname=img2pdf-git
+pkgver=0.1.6-git
+pkgrel=1
+pkgdesc="Losslessly convert images to PDF without unnecessarily re-encoding JPEG and JPEG2000 files. Image quality is retained without unnecessarily increasing file size."
+arch=('any')
+url="https://gitlab.mister-muffin.de/josch/img2pdf"
+license=('LGPL3')
+depends=('python' 'python-pillow' 'python-setuptools')
+makedepends=('git')
+conflicts=("${_name}")
+provides=("${_name}=${pkgver}")
+options=(!emptydirs)
+source=("git+http://gitlab.mister-muffin.de/josch/img2pdf.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ msg "Checking current version..."
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_name}"
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting setup.py..."
+
+ python setup.py build
+}
+
+package() {
+
+ cd "${srcdir}/${_name}"
+ python setup.py install --prefix=/usr --root="$pkgdir"
+}