summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenGi2018-01-15 13:41:04 +0100
committerXenGi2018-01-15 13:41:04 +0100
commit26d00c43c1a3956bf5fcadf845ab1ad08218de76 (patch)
treecc85c0e7fdce118826f9d9dca703dc6c8e735633
parent6ba154f8735c6ea49dcdcc18aaadc8c8f2b00cd9 (diff)
downloadaur-26d00c43c1a3956bf5fcadf845ab1ad08218de76.tar.gz
temporary patch until upstream gets fixed
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--imagemagick7.patch13
3 files changed, 29 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d4186162119..1cdb730d586c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = img2xterm
pkgdesc = Displays images on your 256-color terminal with Unicode block characters
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rossy/img2xterm
arch = any
license = CC0
@@ -10,7 +10,9 @@ pkgbase = img2xterm
optdepends = gimp: palette containing the upper 240 colours used in xterm
options = !emptydirs
source = https://github.com/rossy/img2xterm/archive/v1.0.0.tar.gz
+ source = imagemagick7.patch
sha256sums = 426c682ce61d047f9cf3c3334907dc023475974a5644792591316c137010066e
+ sha256sums = a71a8cf2618396c1c88b60311c45db1c09ed263a74197c2be0fc338a3969a932
pkgname = img2xterm
diff --git a/PKGBUILD b/PKGBUILD
index 952fc31ad9a2..cbd23327a0d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=img2xterm
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Displays images on your 256-color terminal with Unicode block characters"
arch=(any)
url="https://github.com/rossy/img2xterm"
@@ -11,12 +11,21 @@ depends=('imagemagick' 'ncurses')
optdepends=('gimp: palette containing the upper 240 colours used in xterm')
options=(!emptydirs)
install=
-source=("https://github.com/rossy/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('426c682ce61d047f9cf3c3334907dc023475974a5644792591316c137010066e')
+source=("https://github.com/rossy/$pkgname/archive/v$pkgver.tar.gz"
+ "imagemagick7.patch")
+sha256sums=('426c682ce61d047f9cf3c3334907dc023475974a5644792591316c137010066e'
+ 'a71a8cf2618396c1c88b60311c45db1c09ed263a74197c2be0fc338a3969a932')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np1 -i "${srcdir}/imagemagick7.patch"
+}
build() {
+ # build img2xterm
cd "$srcdir/$pkgname-$pkgver"
make
+ # build the GIMP palette
cd "$srcdir/$pkgname-$pkgver/extra"
make
}
@@ -25,5 +34,6 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" PREFIX="$pkgdir/usr" install
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ #install -D -m644 xterm-256color.gpl "${pkgdir}/usr/share/${pkgname}/"
}
diff --git a/imagemagick7.patch b/imagemagick7.patch
new file mode 100644
index 000000000000..b1773c0c30d1
--- /dev/null
+++ b/imagemagick7.patch
@@ -0,0 +1,13 @@
+diff --git a/img2xterm.c b/img2xterm.c
+index 329ec82..b23e3de 100644
+--- a/img2xterm.c
++++ b/img2xterm.c
+@@ -15,7 +15,7 @@
+ #include <string.h>
+ #include <limits.h>
+ #include <math.h>
+-#include <wand/MagickWand.h>
++#include <MagickWand/MagickWand.h>
+
+ #ifndef NO_CURSES
+ #include <term.h>