summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2022-07-25 17:29:57 -0500
committerHurricanePootis2022-07-25 17:29:57 -0500
commit70139e8283c2997bb9224b83337fa23d36364f01 (patch)
treedfa4922a0d84ef7cfc0073c88e4ff6e5d8759637
parent75e5371082ff5336cd0a83908cf505854574bb7c (diff)
downloadaur-70139e8283c2997bb9224b83337fa23d36364f01.tar.gz
Rework submodules, actually cloning from local repos now, and added lexbor
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a2bcd6afeb1..24d18ea212df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = imgbrd-grabber
pkgdesc = Very customizable imageboard/booru downloader with powerful filenaming features.
pkgver = 7.9.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Bionus/imgbrd-grabber
arch = x86_64
license = Apache
@@ -22,10 +22,12 @@ pkgbase = imgbrd-grabber
source = git+https://github.com/Bionus/imgbrd-grabber.git#tag=v7.9.1
source = git+https://github.com/LaurentGomila/qt-android-cmake.git
source = git+https://github.com/sakra/cotire.git
+ source = git+https://github.com/lexbor/lexbor.git
source = git+https://github.com/catchorg/Catch2.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = imgbrd-grabber
diff --git a/PKGBUILD b/PKGBUILD
index 677b15241219..eb92c8154fcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
pkgname=imgbrd-grabber
pkgver=7.9.1
-pkgrel=1
+pkgrel=2
pkgdesc="Very customizable imageboard/booru downloader with powerful filenaming features."
arch=('x86_64')
url="https://github.com/Bionus/imgbrd-grabber"
@@ -13,21 +13,22 @@ conflicts=("imgbrd-grabber-git" 'imgbrd-grabber-bin' 'imgbrd-grabber-appimage')
source=('git+https://github.com/Bionus/imgbrd-grabber.git#tag=v'${pkgver}''
'git+https://github.com/LaurentGomila/qt-android-cmake.git'
'git+https://github.com/sakra/cotire.git'
+ 'git+https://github.com/lexbor/lexbor.git'
+
'git+https://github.com/catchorg/Catch2.git')
sha256sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
cd "$srcdir/${pkgname}"
git submodule init
- git config submodule.qt-android-cmake.url "$srcdir/qt-android-cmake"
- git config submodule.qt-android-cmake.path "$srcdir/${pkgname}/src/cmake/qt-android-cmake"
- git config submodule.cotire.url "$srcdir/cotire"
- git config submodule.cotire.path "$srcdir/${pkgname}/src/cmake/cotire"
- git config submodule.Catch2.url $srcdir/Catch2
- git config submodule.Catch2.path "$srcdir/${pkgname}/src/tests/src/vendor/catch"
+ git config submodule.cmake/qt-android-cmake.url "$srcdir/qt-android-cmake"
+ git config submodule.cmake/cotire.url "$srcdir/cotire"
+ git config submodule.tests/src/vendor/catch.url "$srcdir/Catch2"
+ git config submodule.lib/vendor/lexbor.url "$srcdir/lexbor"
git submodule update
}