summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2022-01-01 22:43:28 -0600
committerHurricanePootis2022-01-01 22:43:28 -0600
commitb8b4d209e5458257a010b7306a94ae87b64ef0c8 (patch)
tree920deaeb6587abc6971a920b7caee9930f638963
parentbbc3ad41d53098232511b32d743a36745446dd13 (diff)
downloadaur-b8b4d209e5458257a010b7306a94ae87b64ef0c8.tar.gz
Update to 7.7.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97ec71dc3e7f..4277903fa8e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = imgbrd-grabber
pkgdesc = Very customizable imageboard/booru downloader with powerful filenaming features.
- pkgver = 7.6.2
+ pkgver = 7.7.0
pkgrel = 1
url = https://github.com/Bionus/imgbrd-grabber
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = imgbrd-grabber
makedepends = cmake
makedepends = qt5-tools
makedepends = npm
- makedepends = clang
+ makedepends = gcc
depends = qt5-multimedia
depends = qt5-declarative
depends = nodejs
@@ -20,7 +20,7 @@ pkgbase = imgbrd-grabber
conflicts = imgbrd-grabber-git
conflicts = imgbrd-grabber-bin
conflicts = imgbrd-grabber-appimage
- source = git+https://github.com/Bionus/imgbrd-grabber.git#tag=v7.6.2
+ source = git+https://github.com/Bionus/imgbrd-grabber.git#tag=v7.7.0
source = git+https://github.com/LaurentGomila/qt-android-cmake.git
source = git+https://github.com/sakra/cotire.git
source = git+https://github.com/catchorg/Catch2.git
diff --git a/PKGBUILD b/PKGBUILD
index 7b13c73ee8e3..4e9db5c0a624 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
pkgname=imgbrd-grabber
-pkgver=7.6.2
+pkgver=7.7.0
pkgrel=1
pkgdesc="Very customizable imageboard/booru downloader with powerful filenaming features."
arch=('x86_64')
url="https://github.com/Bionus/imgbrd-grabber"
license=('Apache')
depends=('qt5-multimedia' 'qt5-declarative' 'nodejs' 'qt5-networkauth' 'qt5-base' 'krb5')
-makedepends=('git' 'cmake' 'qt5-tools' 'npm' 'clang')
+makedepends=('git' 'cmake' 'qt5-tools' 'npm' 'gcc')
optdepends=('openssl: Access HTTPS sources')
conflicts=("imgbrd-grabber-git" 'imgbrd-grabber-bin' 'imgbrd-grabber-appimage')
source=('git+https://github.com/Bionus/imgbrd-grabber.git#tag=v'${pkgver}''
@@ -39,9 +39,7 @@ build() {
cmake "$srcdir/${pkgname%}/src" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_QSCINTILLA=0 \
- -DUSE_BREAKPAD=O \
- -DCMAKE_C_COMPILER=/usr/bin/clang \
- -DCMAKE_CXX_COMPILER=/usr/bin/clang++
+ -DUSE_BREAKPAD=O
make
}